import rust-simple_logger-4.3.3-3.el10

i10ce changed/i10ce/rust-simple_logger-4.3.3-3.el10
MSVSphere Packaging Team 2 months ago
commit b3da6d1989
Signed by: sys_gitsync
GPG Key ID: B2B0B9F29E528FE8

1
.gitignore vendored

@ -0,0 +1 @@
SOURCES/simple_logger-4.3.3.crate

@ -0,0 +1 @@
d0b77c76b55c5caae7c70d07076b7db671fafef5 SOURCES/simple_logger-4.3.3.crate

@ -0,0 +1,12 @@
--- simple_logger-4.3.3/Cargo.toml 1970-01-01T00:00:01+00:00
+++ simple_logger-4.3.3/Cargo.toml 2023-12-31T16:37:14.277130+00:00
@@ -75,9 +75,3 @@
threads = []
timestamps = ["time"]
-[target."cfg(windows)".dependencies.windows-sys]
-version = "^0.48.0"
-features = [
- "Win32_System_Console",
- "Win32_Foundation",
-]

@ -0,0 +1,251 @@
## START: Set by rpmautospec
## (rpmautospec version 0.7.3)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 3;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}
%global crate simple_logger
Name: rust-simple_logger
Version: 4.3.3
Release: %autorelease
Summary: Logger that prints all messages with a readable output format
License: MIT
URL: https://crates.io/crates/simple_logger
Source: %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch: simple_logger-fix-metadata-auto.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
A logger that prints all messages with a readable output format.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+colored-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+colored-devel %{_description}
This package contains library source intended for building other packages which
use the "colored" feature of the "%{crate}" crate.
%files -n %{name}+colored-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+colors-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+colors-devel %{_description}
This package contains library source intended for building other packages which
use the "colors" feature of the "%{crate}" crate.
%files -n %{name}+colors-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+nightly-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+nightly-devel %{_description}
This package contains library source intended for building other packages which
use the "nightly" feature of the "%{crate}" crate.
%files -n %{name}+nightly-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+stderr-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+stderr-devel %{_description}
This package contains library source intended for building other packages which
use the "stderr" feature of the "%{crate}" crate.
%files -n %{name}+stderr-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+threads-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+threads-devel %{_description}
This package contains library source intended for building other packages which
use the "threads" feature of the "%{crate}" crate.
%files -n %{name}+threads-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+time-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+time-devel %{_description}
This package contains library source intended for building other packages which
use the "time" feature of the "%{crate}" crate.
%files -n %{name}+time-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+timestamps-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+timestamps-devel %{_description}
This package contains library source intended for building other packages which
use the "timestamps" feature of the "%{crate}" crate.
%files -n %{name}+timestamps-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 4.3.3-3
- Rebuilt for MSVSphere 10
## START: Generated by rpmautospec
* Sat Jul 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 4.3.3-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
* Sat Jan 27 2024 Fedora Release Engineering <releng@fedoraproject.org> - 4.3.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Sun Dec 31 2023 Fabio Valentini <decathorpe@gmail.com> - 4.3.3-1
- Update to version 4.3.3; Fixes RHBZ#2256212
* Sat Nov 25 2023 Fabio Valentini <decathorpe@gmail.com> - 4.3.0-1
- Update to version 4.3.0; Fixes RHBZ#2251252
* Sat Oct 14 2023 Fabio Valentini <decathorpe@gmail.com> - 4.2.0-1
- Update to version 4.2.0; Fixes RHBZ#2042597
* Sat Aug 05 2023 Fabio Valentini <decathorpe@gmail.com> - 1.16.0-6
- Regenerate with rust2rpm v24
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.16.0-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.16.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.16.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.16.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Wed Dec 15 2021 Fabio Valentini <decathorpe@gmail.com> - 1.16.0-1
- Update to version 1.16.0; Fixes RHBZ#2026721
* Sun Aug 08 2021 Fabio Valentini <decathorpe@gmail.com> - 1.13.0-1
- Update to version 1.13.0; Fixes RHBZ#1991108
* Sat Jul 31 2021 Fabio Valentini <decathorpe@gmail.com> - 1.12.1-1
- Update to version 1.12.1; Fixes RHBZ#1987268
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.11.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.11.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Mon Nov 09 2020 Fabio Valentini <decathorpe@gmail.com> - 1.11.0-1
- Update to version 1.11.0.
- Fixes RHBZ#1884193
* Wed Sep 16 2020 Fabio Valentini <decathorpe@gmail.com> - 1.9.0-1
- Update to version 1.9.0.
* Tue Sep 01 2020 Josh Stone <jistone@redhat.com> - 1.7.0-1
- Update to 1.7.0
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.0-3
- Second attempt - Rebuilt for
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Tue Feb 25 13:09:23 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 1.6.0-1
- Update to 1.6.0
* Tue Jan 28 2020 Josh Stone <jistone@redhat.com> - 1.5.0-1
- Update to 1.5.0
* Wed Jan 15 2020 Josh Stone <jistone@redhat.com> - 1.4.0-1
- Update to 1.4.0
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Tue Jun 11 19:17:15 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.3.0-1
- Update to 1.3.0
* Sun May 12 11:11:57 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.2.0-1
- Update to 1.2.0
* Sat Apr 27 09:28:47 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.0.1-1
- Initial package
## END: Generated by rpmautospec
Loading…
Cancel
Save