Initial import (#2222662)
parent
754a693e7f
commit
1d453181f5
@ -0,0 +1 @@
|
||||
/simd-adler32-0.3.5.crate
|
@ -0,0 +1,108 @@
|
||||
# Generated by rust2rpm 24
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate simd-adler32
|
||||
|
||||
Name: rust-simd-adler32
|
||||
Version: 0.3.5
|
||||
Release: %autorelease
|
||||
Summary: SIMD-accelerated Adler-32 rolling hash algorithm implementation
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/simd-adler32
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
|
||||
Patch: simd-adler32-fix-metadata.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
A SIMD-accelerated Adler-32 rolling hash algorithm implementation.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE.md
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+const-generics-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+const-generics-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "const-generics" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+const-generics-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+nightly-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+nightly-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "nightly" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+nightly-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+std-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+std-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "std" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+std-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
@ -0,0 +1,52 @@
|
||||
--- simd-adler32-0.3.5/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ simd-adler32-0.3.5/Cargo.toml 2023-07-13T11:14:14.407439+00:00
|
||||
@@ -35,49 +35,11 @@
|
||||
opt-level = 2
|
||||
debug = true
|
||||
|
||||
-[[bench]]
|
||||
-name = "all"
|
||||
-path = "bench/all.rs"
|
||||
-harness = false
|
||||
-
|
||||
-[[bench]]
|
||||
-name = "avx2"
|
||||
-path = "bench/avx2.rs"
|
||||
-harness = false
|
||||
-
|
||||
-[[bench]]
|
||||
-name = "avx512"
|
||||
-path = "bench/avx512.rs"
|
||||
-harness = false
|
||||
-
|
||||
-[[bench]]
|
||||
-name = "scalar"
|
||||
-path = "bench/scalar.rs"
|
||||
-harness = false
|
||||
-
|
||||
-[[bench]]
|
||||
-name = "sse2"
|
||||
-path = "bench/sse2.rs"
|
||||
-harness = false
|
||||
-
|
||||
-[[bench]]
|
||||
-name = "ssse3"
|
||||
-path = "bench/ssse3.rs"
|
||||
-harness = false
|
||||
-
|
||||
-[[bench]]
|
||||
-name = "compete"
|
||||
-path = "bench/compete.rs"
|
||||
-harness = false
|
||||
-
|
||||
[dev-dependencies.adler]
|
||||
version = "1.0.2"
|
||||
|
||||
[dev-dependencies.adler32]
|
||||
version = "1.2.0"
|
||||
-
|
||||
-[dev-dependencies.criterion]
|
||||
-version = "0.3"
|
||||
|
||||
[dev-dependencies.rand]
|
||||
version = "0.8"
|
Loading…
Reference in new issue