Update to version 0.1.7; Fixes RHBZ#2241079

epel9 imports/e9/rust-sharded-slab-0.1.7-1.el9
Fabio Valentini 1 year ago
parent ddddf3bd43
commit a354ea27c9
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -1,2 +1,3 @@
/sharded-slab-0.1.4.crate /sharded-slab-0.1.4.crate
/sharded-slab-0.1.5.crate /sharded-slab-0.1.5.crate
/sharded-slab-0.1.7.crate

@ -1,23 +1,20 @@
# Generated by rust2rpm 24 # Generated by rust2rpm 25
%bcond_without check # * missing dev-dependencies: memory-stats
%bcond_with check
%global debug_package %{nil} %global debug_package %{nil}
%global crate sharded-slab %global crate sharded-slab
Name: rust-sharded-slab Name: rust-sharded-slab
Version: 0.1.5 Version: 0.1.7
Release: %autorelease Release: %autorelease
Summary: Lock-free concurrent slab Summary: Lock-free concurrent slab
License: MIT License: MIT
URL: https://crates.io/crates/sharded-slab URL: https://crates.io/crates/sharded-slab
Source: %{crates_source} Source: %{crates_source}
# Automatically generated patch to strip foreign dependencies # Automatically generated patch to strip dependencies and normalize metadata
Patch: sharded-slab-fix-metadata-auto.diff Patch: sharded-slab-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
# * drop unused loom dev-dependency
Patch: sharded-slab-fix-metadata.diff
BuildRequires: rust-packaging >= 21 BuildRequires: rust-packaging >= 21
@ -55,7 +52,7 @@ use the "default" feature of the "%{crate}" crate.
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version} -p1
%cargo_prep %cargo_prep
%generate_buildrequires %generate_buildrequires

@ -0,0 +1,3 @@
[tests]
run = ["none"]
comments = ["missing dev-dependencies: memory-stats"]

@ -1,6 +1,6 @@
--- sharded-slab-0.1.5/Cargo.toml 1970-01-01T00:00:01+00:00 --- sharded-slab-0.1.7/Cargo.toml 1970-01-01T00:00:01+00:00
+++ sharded-slab-0.1.5/Cargo.toml 2023-08-28T19:50:58.767462+00:00 +++ sharded-slab-0.1.7/Cargo.toml 2023-10-07T12:50:37.676130+00:00
@@ -61,10 +61,5 @@ @@ -64,14 +64,6 @@
[dev-dependencies.slab] [dev-dependencies.slab]
version = "0.4.2" version = "0.4.2"
@ -8,6 +8,11 @@
-version = "0.5" -version = "0.5"
-features = ["checkpoint"] -features = ["checkpoint"]
-optional = true -optional = true
-
-[target."cfg(loom)".dev-dependencies.loom]
-version = "0.5"
-features = ["checkpoint"]
- -
[badges.maintenance] [badges.maintenance]
status = "experimental" status = "experimental"
+

@ -1,16 +0,0 @@
--- sharded-slab-0.1.5/Cargo.toml 1970-01-01T00:00:01+00:00
+++ sharded-slab-0.1.5/Cargo.toml 2023-08-28T19:51:25.416585+00:00
@@ -48,13 +48,6 @@
[dependencies.lazy_static]
version = "1"
-[dev-dependencies.criterion]
-version = "0.3"
-
-[dev-dependencies.loom]
-version = "0.5"
-features = ["checkpoint"]
-
[dev-dependencies.proptest]
version = "1"

@ -1 +1 @@
SHA512 (sharded-slab-0.1.5.crate) = 38609a8391223602d86385d0c3e422f6102eeebf65b48f8957a61fdf16f5924244be1e45e1d08facfda83590a8fd709edd266d009bbb3ebd4d8ea18bdc2221c0 SHA512 (sharded-slab-0.1.7.crate) = 3be7438d4a75debb14463477f34de6db1ac38abe958ada5d5dae7ae8d5993e245da69fcb989d91aaaffda5f2b085d4bcc88d10e07ec567b7f40a21437de6d4cb

Loading…
Cancel
Save