Initial import (#2051039)

epel9
Fabio Valentini 3 years ago
parent fd7052d9d6
commit 6572d8e5eb
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -0,0 +1 @@
/sharded-slab-0.1.4.crate

@ -1,3 +0,0 @@
# rust-sharded-slab
The rust-sharded-slab package

@ -0,0 +1,77 @@
# Generated by rust2rpm 21
%bcond_without check
%global debug_package %{nil}
%global crate sharded-slab
Name: rust-%{crate}
Version: 0.1.4
Release: %autorelease
Summary: Lock-free concurrent slab
# Upstream license specification: MIT
License: MIT
URL: https://crates.io/crates/sharded-slab
Source: %{crates_source}
# Initial patched metadata
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
# * drop unused loom dev-dependency
Patch0: sharded-slab-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Lock-free concurrent slab.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/IMPLEMENTATION.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog

@ -0,0 +1,24 @@
--- sharded-slab-0.1.4/Cargo.toml 1970-01-01T00:00:01+00:00
+++ sharded-slab-0.1.4/Cargo.toml 2022-05-04T11:25:08.424636+00:00
@@ -31,21 +31,11 @@
harness = false
[dependencies.lazy_static]
version = "1"
-[dev-dependencies.criterion]
-version = "0.3"
-
-[dev-dependencies.loom]
-version = "0.5"
-features = ["checkpoint"]
[dev-dependencies.proptest]
version = "1"
[dev-dependencies.slab]
version = "0.4.2"
-[target."cfg(loom)".dependencies.loom]
-version = "0.5"
-features = ["checkpoint"]
-optional = true
[badges.maintenance]
status = "experimental"

@ -0,0 +1 @@
SHA512 (sharded-slab-0.1.4.crate) = 123a9ddb126d1adf41a30a632604264d66a06bacc497db6373e9dd36164197f8321f2fc826a16247674f0f69d9f6e30aca37810f787693c4a5c2cee8c5887c55
Loading…
Cancel
Save