Update to 0.8.2

Signed-off-by: Igor Raits <ignatenkobrain@fedoraproject.org>
epel9
Igor Raits 5 years ago
parent c65d3ecbe9
commit a8d3e43489
No known key found for this signature in database
GPG Key ID: 115D5AB89C5C1E1E

1
.gitignore vendored

@ -1,2 +1,3 @@
/sha2-0.8.0.crate /sha2-0.8.0.crate
/sha2-0.8.1.crate /sha2-0.8.1.crate
/sha2-0.8.2.crate

@ -1,12 +1,12 @@
# Generated by rust2rpm 13 # Generated by rust2rpm 15
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate sha2 %global crate sha2
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.8.1 Version: 0.8.2
Release: 2%{?dist} Release: 1%{?dist}
Summary: SHA-2 hash functions Summary: SHA-2 hash functions
# Upstream license specification: MIT OR Apache-2.0 # Upstream license specification: MIT OR Apache-2.0
@ -15,7 +15,6 @@ URL: https://crates.io/crates/sha2
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Initial patched metadata
# * Update hex-literal to 0.2, https://github.com/RustCrypto/hashes/pull/85 # * Update hex-literal to 0.2, https://github.com/RustCrypto/hashes/pull/85
# * Remove unstable asm features
Patch0: sha2-fix-metadata.diff Patch0: sha2-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
@ -26,7 +25,8 @@ BuildArch: noarch
BuildRequires: rust-packaging BuildRequires: rust-packaging
%global _description %{expand: %global _description %{expand:
SHA-2 hash functions.} Pure Rust implementation of the SHA-2 hash function family including SHA-224,
SHA-256, SHA-384, and SHA-512.}
%description %{_description} %description %{_description}
@ -55,6 +55,66 @@ which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+asm-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+asm-devel %{_description}
This package contains library source intended for building other packages
which use "asm" feature of "%{crate}" crate.
%files -n %{name}+asm-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+asm-aarch64-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+asm-aarch64-devel %{_description}
This package contains library source intended for building other packages
which use "asm-aarch64" feature of "%{crate}" crate.
%files -n %{name}+asm-aarch64-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+compress-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+compress-devel %{_description}
This package contains library source intended for building other packages
which use "compress" feature of "%{crate}" crate.
%files -n %{name}+compress-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+libc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+libc-devel %{_description}
This package contains library source intended for building other packages
which use "libc" feature of "%{crate}" crate.
%files -n %{name}+libc-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+sha2-asm-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+sha2-asm-devel %{_description}
This package contains library source intended for building other packages
which use "sha2-asm" feature of "%{crate}" crate.
%files -n %{name}+sha2-asm-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+std-devel %package -n %{name}+std-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -86,6 +146,9 @@ which use "std" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Sun May 24 12:28:18 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.8.2-1
- Update to 0.8.2
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.1-2 * Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

@ -1,21 +1,6 @@
--- sha2-0.8.1/Cargo.toml 2020-01-06T02:55:40+00:00 --- sha2-0.8.2/Cargo.toml 2020-05-24T00:14:45+00:00
+++ sha2-0.8.1/Cargo.toml 2020-01-07T18:11:28.488572+00:00 +++ sha2-0.8.2/Cargo.toml 2020-05-24T10:28:18.806695+00:00
@@ -29,26 +29,17 @@ @@ -44,7 +44,7 @@
[dependencies.fake-simd]
version = "0.1"
-[dependencies.libc]
-version = "0.2"
-optional = true
-
[dependencies.opaque-debug]
version = "0.2"
-[dependencies.sha2-asm]
-version = "0.5"
-optional = true
[dev-dependencies.digest]
version = "0.8"
features = ["dev"] features = ["dev"]
[dev-dependencies.hex-literal] [dev-dependencies.hex-literal]
@ -23,8 +8,4 @@
+version = "0.2" +version = "0.2"
[features] [features]
-asm = ["sha2-asm"] asm = ["sha2-asm"]
-asm-aarch64 = ["asm", "libc"]
default = ["std"]
std = ["digest/std"]
[badges.travis-ci]

@ -1 +1 @@
SHA512 (sha2-0.8.1.crate) = b2de5cd8476b7c709fad0996c2e0c7bf577e077e7d5f70c47b780fb41c7cf8e75d156958a5519a7cac9f390d91b4c044590ecc9be0953e0632f54e7c063109ad SHA512 (sha2-0.8.2.crate) = a9c2c9ccc846fd73d12fe9120ad1fb224bc35475c7332379a9cc67a7889677ddb1c577489d3a1aeae24e98b397b321823010c20ab3aca172839b2ea1fdc89da8

Loading…
Cancel
Save