Update to version 0.10.1; Fixes RHBZ#2041179

epel9
Fabio Valentini 3 years ago
parent 7456525b19
commit 41ad855d30
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

2
.gitignore vendored

@ -1,3 +1,5 @@
/sha1-0.2.0.crate /sha1-0.2.0.crate
/sha1-0.4.0.crate /sha1-0.4.0.crate
/sha1-0.6.0.crate /sha1-0.6.0.crate
/sha1-0.10.0.crate
/sha1-0.10.1.crate

@ -0,0 +1,4 @@
[DEFAULT]
unwanted-features =
asm
sha1-asm

@ -1,25 +0,0 @@
From 27c7f771d43fdab5a54af6bad190830262d12474 Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <ignatenko@redhat.com>
Date: Thu, 26 Apr 2018 09:35:50 +0200
Subject: [PATCH] guard hexdigest() doctest by cfg(feature=std)
Fixes: https://github.com/mitsuhiko/rust-sha1/issues/34
---
src/lib.rs | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/lib.rs b/src/lib.rs
index 446c98b..a83e1e6 100644
--- a/src/lib.rs
+++ b/src/lib.rs
@@ -26,6 +26,7 @@
//! ```
//! extern crate sha1;
//! # fn main() {
+//! #[cfg(feature="std")]
//! assert_eq!(sha1::Sha1::from("Hello World!").hexdigest(),
//! "2ef7bde608ce5404e97d5f042f95f89f1c232871");
//! # }
--
2.17.0

@ -1,30 +1,25 @@
# Generated by rust2rpm 10 # Generated by rust2rpm 20
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate sha1 %global crate sha1
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.6.0 Version: 0.10.1
Release: %autorelease Release: %autorelease
Summary: Minimal implementation of SHA1 for Rust Summary: SHA-1 hash function
# Upstream license specification: BSD-3-Clause # Upstream license specification: MIT OR Apache-2.0
License: BSD License: MIT or ASL 2.0
URL: https://crates.io/crates/sha1 URL: https://crates.io/crates/sha1
Source: %{crates_source} Source: %{crates_source}
# https://github.com/mitsuhiko/rust-sha1/pull/35
Patch0001: 0001-guard-hexdigest-doctest-by-cfg-feature-std.patch
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging BuildRequires: rust-packaging
%global _description %{expand: %global _description %{expand:
Minimal implementation of SHA1 for Rust.} SHA-1 hash function.}
%description %{_description} %description %{_description}
@ -34,14 +29,13 @@ BuildArch: noarch
%description devel %{_description} %description devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license LICENSE %license LICENSE-APACHE LICENSE-MIT
%doc README.md %doc CHANGELOG.md README.md
%{cargo_registry}/%{crate}-%{version}/ %{cargo_registry}/%{crate}-%{version_no_tilde}/
%exclude %{cargo_registry}/%{crate}-%{version}/{Makefile,upload-docs.sh}
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -49,23 +43,35 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description} %description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "default" feature of "%{crate}" crate. use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+compress-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+compress-devel %{_description}
This package contains library source intended for building other packages which
use the "compress" feature of the "%{crate}" crate.
%files -n %{name}+compress-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+serde-devel %package -n %{name}+force-soft-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
%description -n %{name}+serde-devel %{_description} %description -n %{name}+force-soft-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "serde" feature of "%{crate}" crate. use the "force-soft" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel %files -n %{name}+force-soft-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+std-devel %package -n %{name}+std-devel
Summary: %{summary} Summary: %{summary}
@ -73,11 +79,11 @@ BuildArch: noarch
%description -n %{name}+std-devel %{_description} %description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "std" feature of "%{crate}" crate. use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel %files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1

@ -1 +1 @@
SHA512 (sha1-0.6.0.crate) = 32081c99a0cd5fd6e651deb711eb4c9a8bc71c12e26b25a72b2dba9a3286502e56b23d068a2899764ce1cc0c615c2c1b22a6c7aae63e07a758745b533e70ff0c SHA512 (sha1-0.10.1.crate) = 5f32cfff707d08dfcf0c826ddd723fbdb7e1e29614f6b303c2707dd75ef3b599a5e2b48ebdd570e2e731b02dbcbe2557e91f2d1c5cb44d0afb3d8a46c38c89a4

Loading…
Cancel
Save