Update to 0.6.0

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 7 years ago
parent 4ff8732386
commit 1371986ad6
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -1,2 +1,3 @@
/sha1-0.2.0.crate
/sha1-0.4.0.crate
/sha1-0.6.0.crate

@ -1,26 +0,0 @@
From fdc4e5c7507f8beb55326357bce4a7f90f97a953 Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date: Sat, 13 Jan 2018 11:15:25 +0100
Subject: [PATCH] deps: update openssl to 0.10
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
---
src/lib.rs | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/lib.rs b/src/lib.rs
index e29f263..29cb09b 100644
--- a/src/lib.rs
+++ b/src/lib.rs
@@ -526,7 +526,7 @@ mod tests {
m.update(&bytes[..len]);
r.update(&bytes[..len]).unwrap();
}
- assert_eq!(r.finish2().unwrap().as_ref(), &m.digest().bytes());
+ assert_eq!(r.finish().unwrap().as_ref(), &m.digest().bytes());
}
}
}
--
2.15.1

@ -5,27 +5,24 @@
%global crate sha1
Name: rust-%{crate}
Version: 0.4.0
Release: 4%{?dist}
Version: 0.6.0
Release: 1%{?dist}
Summary: Minimal implementation of SHA1 for Rust
License: BSD
URL: https://crates.io/crates/sha1
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Bump rand to 0.4, https://github.com/mitsuhiko/rust-sha1/pull/26
# * Bump openssl to 0.10, https://github.com/mitsuhiko/rust-sha1/pull/28
Patch0: sha1-0.4.0-fix-metadata.diff
# Make it work with openssl v0.10
Patch1: 0001-deps-update-openssl-to-0.10.patch
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(serde) >= 1.0.0 with crate(serde) < 2.0.0)
%if %{with check}
# [dev-dependencies]
BuildRequires: (crate(openssl) >= 0.10.0 with crate(openssl) < 0.11.0)
BuildRequires: (crate(rand) >= 0.4.0 with crate(rand) < 0.5.0)
BuildRequires: (crate(serde_json) >= 1.0.0 with crate(serde_json) < 2.0.0)
%endif
%description
@ -60,8 +57,12 @@ which use %{crate} from crates.io.
%license LICENSE
%doc README.md
%{cargo_registry}/%{crate}-%{version}/
%exclude %{cargo_registry}/%{crate}-%{version}/{Makefile,upload-docs.sh}
%changelog
* Thu Apr 26 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.0-1
- Update to 0.6.0
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

@ -1,12 +0,0 @@
--- sha1-0.4.0/Cargo.toml 1970-01-01T01:00:00+01:00
+++ sha1-0.4.0/Cargo.toml 2018-01-13T13:01:51.368568+01:00
@@ -19,7 +19,7 @@
license = "BSD-3-Clause"
repository = "https://github.com/mitsuhiko/rust-sha1"
[dev-dependencies.openssl]
-version = "0.9"
+version = "0.10"
[dev-dependencies.rand]
-version = "0.3"
+version = "0.4"

@ -1 +1 @@
SHA512 (sha1-0.4.0.crate) = 4ed4fd956e652b3dc42ea1cb476db12e312f288f641b2ecadfb7312d88c3a04d227b1d0f17547b0989e082854aec4f5889ae3c51ec1201b9abaaee89bafd9378
SHA512 (sha1-0.6.0.crate) = 32081c99a0cd5fd6e651deb711eb4c9a8bc71c12e26b25a72b2dba9a3286502e56b23d068a2899764ce1cc0c615c2c1b22a6c7aae63e07a758745b533e70ff0c

Loading…
Cancel
Save