Initial import.

Signed-off-by: Randy Barlow <randy@electronsweatshop.com>
epel9
Randy Barlow 6 years ago
parent cefc09fd48
commit ccbe8dca8d

@ -0,0 +1,95 @@
# Generated by rust2rpm
# We don't have the dev dependencies packaged yet, so disable the tests for now.
%bcond_with check
%global debug_package %{nil}
%global crate sha-1
Name: rust-%{crate}
Version: 0.8.1
Release: 1%{?dist}
Summary: SHA-1 hash function
# Upstream license specification: MIT OR Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/sha-1
Source: %{crates_source}
# Initial patched metadata
# sha-1-asm is x86-specific and is also optional, so we can drop it for now.
Patch0: sha-1-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: (crate(block-buffer/default) >= 0.7.0 with crate(block-buffer/default) < 0.8.0)
BuildRequires: (crate(digest/default) >= 0.8.0 with crate(digest/default) < 0.9.0)
BuildRequires: (crate(digest/std) >= 0.8.0 with crate(digest/std) < 0.9.0)
BuildRequires: (crate(fake-simd/default) >= 0.1.0 with crate(fake-simd/default) < 0.2.0)
BuildRequires: (crate(opaque-debug/default) >= 0.2.0 with crate(opaque-debug/default) < 0.3.0)
%if %{with check}
BuildRequires: (crate(digest/default) >= 0.8.0 with crate(digest/default) < 0.9.0)
BuildRequires: (crate(digest/dev) >= 0.8.0 with crate(digest/dev) < 0.9.0)
BuildRequires: (crate(hex-literal/default) >= 0.1.0 with crate(hex-literal/default) < 0.2.0)
%endif
%global _description \
SHA-1 hash function.
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
%files devel
%{cargo_registry}/%{crate}-%{version}/
%license LICENSE-APACHE
%license LICENSE-MIT
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages
which use "std" feature of "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Sat Feb 23 2019 Randy Barlow <randy@electronsweatshop.com> - 0.8.1-1
- Initial package

Binary file not shown.

@ -0,0 +1,20 @@
--- sha-1-0.8.1/Cargo.toml 1969-12-31T19:00:00-05:00
+++ sha-1-0.8.1/Cargo.toml 2019-02-23T13:15:01.940311-05:00
@@ -35,9 +35,6 @@
[dependencies.opaque-debug]
version = "0.2"
-[dependencies.sha1-asm]
-version = "0.4"
-optional = true
[dev-dependencies.digest]
version = "0.8"
features = ["dev"]
@@ -46,7 +43,6 @@
version = "0.1"
[features]
-asm = ["sha1-asm"]
default = ["std"]
std = ["digest/std"]
[badges.travis-ci]
Loading…
Cancel
Save