Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent fc9c246588
commit b6cafcd291
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -1,13 +1,12 @@
# Generated by rust2rpm # Generated by rust2rpm 10
# We don't have the dev dependencies packaged yet, so disable the tests for now. %bcond_without check
%bcond_with check
%global debug_package %{nil} %global debug_package %{nil}
%global crate sha-1 %global crate sha-1
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.8.1 Version: 0.8.1
Release: 2%{?dist} Release: 3%{?dist}
Summary: SHA-1 hash function Summary: SHA-1 hash function
# Upstream license specification: MIT OR Apache-2.0 # Upstream license specification: MIT OR Apache-2.0
@ -15,25 +14,18 @@ License: MIT or ASL 2.0
URL: https://crates.io/crates/sha-1 URL: https://crates.io/crates/sha-1
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Initial patched metadata
# sha-1-asm is x86-specific and is also optional, so we can drop it for now. # * Update hex-literal to 0.2, https://github.com/RustCrypto/hashes/pull/85
Patch0: sha-1-fix-metadata.diff Patch0: sha-1-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging BuildRequires: rust-packaging
BuildRequires: (crate(block-buffer/default) >= 0.7.0 with crate(block-buffer/default) < 0.8.0)
BuildRequires: (crate(digest/default) >= 0.8.0 with crate(digest/default) < 0.9.0)
BuildRequires: (crate(digest/std) >= 0.8.0 with crate(digest/std) < 0.9.0)
BuildRequires: (crate(fake-simd/default) >= 0.1.0 with crate(fake-simd/default) < 0.2.0)
BuildRequires: (crate(opaque-debug/default) >= 0.2.0 with crate(opaque-debug/default) < 0.3.0)
%if %{with check}
BuildRequires: (crate(digest/default) >= 0.8.0 with crate(digest/default) < 0.9.0)
BuildRequires: (crate(digest/dev) >= 0.8.0 with crate(digest/dev) < 0.9.0)
BuildRequires: (crate(hex-literal/default) >= 0.1.0 with crate(hex-literal/default) < 0.2.0)
%endif
%global _description \ %global _description %{expand:
SHA-1 hash function. SHA-1 hash function.}
%description %{_description} %description %{_description}
@ -62,6 +54,30 @@ which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml %ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+asm-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+asm-devel %{_description}
This package contains library source intended for building other packages
which use "asm" feature of "%{crate}" crate.
%files -n %{name}+asm-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+sha1-asm-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+sha1-asm-devel %{_description}
This package contains library source intended for building other packages
which use "sha1-asm" feature of "%{crate}" crate.
%files -n %{name}+sha1-asm-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+std-devel %package -n %{name}+std-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -78,6 +94,9 @@ which use "std" feature of "%{crate}" crate.
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep %cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build %build
%cargo_build %cargo_build
@ -90,6 +109,9 @@ which use "std" feature of "%{crate}" crate.
%endif %endif
%changelog %changelog
* Sun Jun 23 10:30:56 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.8.1-3
- Regenerate
* Mon Feb 25 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.8.1-2 * Mon Feb 25 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.8.1-2
- Trivial fixes - Trivial fixes

@ -1,20 +1,11 @@
--- sha-1-0.8.1/Cargo.toml 1969-12-31T19:00:00-05:00 --- sha-1-0.8.1/Cargo.toml 1970-01-01T00:00:00+00:00
+++ sha-1-0.8.1/Cargo.toml 2019-02-23T13:15:01.940311-05:00 +++ sha-1-0.8.1/Cargo.toml 2019-06-23T08:30:56.452978+00:00
@@ -35,9 +35,6 @@ @@ -43,7 +43,7 @@
[dependencies.opaque-debug]
version = "0.2"
-[dependencies.sha1-asm]
-version = "0.4"
-optional = true
[dev-dependencies.digest]
version = "0.8"
features = ["dev"] features = ["dev"]
@@ -46,7 +43,6 @@
version = "0.1" [dev-dependencies.hex-literal]
-version = "0.1"
+version = "0.2"
[features] [features]
-asm = ["sha1-asm"] asm = ["sha1-asm"]
default = ["std"]
std = ["digest/std"]
[badges.travis-ci]

Loading…
Cancel
Save