Initial package (rhbz#2271126)

Signed-off-by: Michel Lind <salimma@fedoraproject.org>
epel10
Michel Lind 11 months ago
parent 2ada573df3
commit 591db3dd65
No known key found for this signature in database
GPG Key ID: 8B229D2F7CCC04F2

1
.gitignore vendored

@ -0,0 +1 @@
/serial_test-2.0.0.crate

@ -0,0 +1,143 @@
# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate serial_test
Name: rust-serial_test2
Version: 2.0.0
Release: %autorelease
Summary: Allows for the creation of serialised Rust tests
License: MIT
URL: https://crates.io/crates/serial_test
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop doc-specific dependencies (only used when building docs on docs.rs)
Patch: serial_test-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Allows for the creation of serialised Rust tests.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+async-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+async-devel %{_description}
This package contains library source intended for building other packages which
use the "async" feature of the "%{crate}" crate.
%files -n %{name}+async-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+file_locks-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+file_locks-devel %{_description}
This package contains library source intended for building other packages which
use the "file_locks" feature of the "%{crate}" crate.
%files -n %{name}+file_locks-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fslock-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+fslock-devel %{_description}
This package contains library source intended for building other packages which
use the "fslock" feature of the "%{crate}" crate.
%files -n %{name}+fslock-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+futures-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+futures-devel %{_description}
This package contains library source intended for building other packages which
use the "futures" feature of the "%{crate}" crate.
%files -n %{name}+futures-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+log-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+log-devel %{_description}
This package contains library source intended for building other packages which
use the "log" feature of the "%{crate}" crate.
%files -n %{name}+log-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+logging-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+logging-devel %{_description}
This package contains library source intended for building other packages which
use the "logging" feature of the "%{crate}" crate.
%files -n %{name}+logging-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog

@ -0,0 +1,20 @@
--- serial_test-2.0.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ serial_test-2.0.0/Cargo.toml 2024-03-22T21:00:18.151671+00:00
@@ -34,10 +34,6 @@
[dependencies.dashmap]
version = "5"
-
-[dependencies.document-features]
-version = "0.2"
-optional = true
[dependencies.fslock]
version = "0.2"
@@ -81,6 +77,5 @@
"logging",
"async",
]
-docsrs = ["document-features"]
file_locks = ["fslock"]
logging = ["log"]

@ -0,0 +1 @@
SHA512 (serial_test-2.0.0.crate) = 65bbba74ddf39c3437b3afa327f7cb1befad12a81e639bc6285608211621b444dbf81edfde8b1b85c708a873c105d27aaf0d2f2d4dcac8872c68d92849c8f3dc
Loading…
Cancel
Save