commit
7ad7ed90f6
Binary file not shown.
@ -0,0 +1,20 @@
|
|||||||
|
--- serial_test-1.0.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ serial_test-1.0.0/Cargo.toml 2023-06-22T15:50:25.230034+00:00
|
||||||
|
@@ -34,10 +34,6 @@
|
||||||
|
|
||||||
|
[dependencies.dashmap]
|
||||||
|
version = "5"
|
||||||
|
-
|
||||||
|
-[dependencies.document-features]
|
||||||
|
-version = "0.2"
|
||||||
|
-optional = true
|
||||||
|
|
||||||
|
[dependencies.fslock]
|
||||||
|
version = "0.2"
|
||||||
|
@@ -81,6 +77,5 @@
|
||||||
|
"logging",
|
||||||
|
"async",
|
||||||
|
]
|
||||||
|
-docsrs = ["document-features"]
|
||||||
|
file_locks = ["fslock"]
|
||||||
|
logging = ["log"]
|
@ -0,0 +1,157 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.3.5)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 1;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 24
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate serial_test
|
||||||
|
|
||||||
|
Name: rust-serial_test1
|
||||||
|
Version: 1.0.0
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Allows for the creation of serialised Rust tests
|
||||||
|
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/serial_test
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * drop doc-specific dependencies (only used when building docs on docs.rs)
|
||||||
|
Patch: serial_test-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Allows for the creation of serialised Rust tests.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+async-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+async-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "async" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+async-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+file_locks-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+file_locks-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "file_locks" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+file_locks-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+fslock-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+fslock-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "fslock" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+fslock-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+futures-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+futures-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "futures" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+futures-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+log-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+log-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "log" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+log-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+logging-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+logging-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "logging" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+logging-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 1.0.0-1
|
||||||
|
- Rebuilt for MSVSphere 9.3
|
||||||
|
|
||||||
|
* Thu Jun 22 2023 Fabio Valentini <decathorpe@gmail.com> - 1.0.0-1
|
||||||
|
- Initial import (serial_test 1 compat package)
|
Loading…
Reference in new issue