Resolves: rhbz#1886463 Signed-off-by: Javier Martinez Canillas <javierm@redhat.com>epel9
parent
015b82c620
commit
be183dc3ee
@ -0,0 +1 @@
|
|||||||
|
/serial_test-*.crate
|
@ -0,0 +1,80 @@
|
|||||||
|
# Generated by rust2rpm 15
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate serial_test
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 0.5.0
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Allows for the creation of serialised Rust tests
|
||||||
|
|
||||||
|
# Upstream license specification: MIT
|
||||||
|
# The LICENSE file is not present in the sub-crate but this has already been
|
||||||
|
# fixed upstream: https://github.com/palfrey/serial_test/commit/4997bc3d56d.
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/serial_test
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Initial patched metadata
|
||||||
|
# * Change parking_lot crate dependency version.
|
||||||
|
Patch0: serial_test-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
%if %{__cargo_skip_build}
|
||||||
|
BuildArch: noarch
|
||||||
|
%endif
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Allows for the creation of serialised Rust tests.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%doc README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "default" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Oct 27 17:16:37 CET 2020 Javier Martinez Canillas <javierm@redhat.com> - 0.5.0-1
|
||||||
|
- Initial package
|
||||||
|
Resolves: rhbz#1886463
|
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/Cargo.toml b/Cargo.toml
|
||||||
|
index b9a633e65d2..fdb4d953c54 100644
|
||||||
|
--- a/Cargo.toml
|
||||||
|
+++ b/Cargo.toml
|
||||||
|
@@ -24,7 +24,7 @@ repository = "https://github.com/palfrey/serial_test/"
|
||||||
|
version = "1.2"
|
||||||
|
|
||||||
|
[dependencies.parking_lot]
|
||||||
|
-version = "0.10"
|
||||||
|
+version = "0.11"
|
||||||
|
|
||||||
|
[dependencies.serial_test_derive]
|
||||||
|
version = "~0.5.0"
|
Loading…
Reference in new issue