initial import

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 7 years ago
parent 861d898318
commit 4343b1f2a2

1
.gitignore vendored

@ -0,0 +1 @@
/serde_yaml-0.7.1.crate

@ -0,0 +1,69 @@
# Generated by rust2rpm
%bcond_without check
%global debug_package %{nil}
%global crate serde_yaml
Name: rust-%{crate}
Version: 0.7.1
Release: 1%{?dist}
Summary: YAML support for Serde
License: MIT or ASL 2.0
URL: https://crates.io/crates/serde_yaml
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Bump linked-hash-map to 0.5, https://github.com/dtolnay/serde-yaml/commit/61d451077f7f88a0f3c6b61eceadb9ee17e26fed
Patch0: serde_yaml-0.7.1-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
# [dependencies]
BuildRequires: (crate(linked-hash-map) >= 0.5.0 with crate(linked-hash-map) < 0.6.0)
BuildRequires: (crate(num-traits) >= 0.1.37 with crate(num-traits) < 0.2.0)
BuildRequires: (crate(serde) >= 1.0.0 with crate(serde) < 2.0.0)
BuildRequires: ((crate(yaml-rust) >= 0.3.5 with crate(yaml-rust) < 0.4.0) with crate(yaml-rust/preserve_order))
%if %{with check}
# [dev-dependencies]
BuildRequires: (crate(serde_derive) >= 1.0.0 with crate(serde_derive) < 2.0.0)
BuildRequires: (crate(unindent) >= 0.1.0 with crate(unindent) < 0.2.0)
%endif
%description
%{summary}.
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel
YAML support for Serde.
This package contains library source intended for building other packages
which use %{crate} from crates.io.
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%files devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.md
%{cargo_registry}/%{crate}-%{version}/
%exclude %{cargo_registry}/%{crate}-%{version}/travis.sh
%changelog
* Tue Nov 14 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.1-1
- Initial package

@ -0,0 +1,11 @@
--- serde_yaml-0.7.1/Cargo.toml 1970-01-01T01:00:00+01:00
+++ serde_yaml-0.7.1/Cargo.toml 2017-11-14T14:10:22.927249+01:00
@@ -31,7 +31,7 @@
version = "1.0"
[dependencies.linked-hash-map]
-version = "0.4"
+version = "0.5"
[dev-dependencies.unindent]
version = "0.1"

@ -0,0 +1 @@
SHA512 (serde_yaml-0.7.1.crate) = 87b6d733edf20be4df7797e118f7280dacc5307d464967c8602611c2187a3768dd96eb80e063cfef836bc6344e678cd681fcb993b31d7f33a44ba0ffb65a7d21
Loading…
Cancel
Save