parent
49f5efef6c
commit
fa555e5afe
@ -0,0 +1 @@
|
||||
/serde_with-*.crate
|
@ -0,0 +1,128 @@
|
||||
# Generated by rust2rpm 18
|
||||
%bcond_with check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate serde_with
|
||||
|
||||
%global __cargo_parse_opts --features=chrono_crate,serde_json
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 1.9.4
|
||||
Release: 1%{?dist}
|
||||
Summary: Custom de/serialization functions for Rust's serde
|
||||
|
||||
# Upstream license specification: MIT OR Apache-2.0
|
||||
License: MIT or ASL 2.0
|
||||
URL: https://crates.io/crates/serde_with
|
||||
Source: %{crates_source}
|
||||
# cargo-inspector doesn't support disabling default features
|
||||
# https://pagure.io/fedora-rust/rust2rpm/issue/140
|
||||
Patch0: serde_with-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
%if %{__cargo_skip_build}
|
||||
BuildArch: noarch
|
||||
%endif
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%global _description %{expand:
|
||||
Custom de/serialization functions for Rust's serde.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license LICENSE-MIT LICENSE-APACHE
|
||||
%doc README.tpl README.md CHANGELOG.md src/guide.md src/guide/serde_as.md src/guide/feature_flags.md
|
||||
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "default" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+chrono-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+chrono-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "chrono" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+chrono-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+chrono_crate-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+chrono_crate-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "chrono_crate" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+chrono_crate-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+hex-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+hex-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "hex" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+hex-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+json-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+json-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "json" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+json-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sat Jul 31 2021 Peter Robinson <pbrobinson@gmail.com> - 1.9.4-1
|
||||
- Initial package
|
@ -0,0 +1,10 @@
|
||||
--- serde_with-1.9.4/Cargo.toml.orig 2021-08-11 09:54:50.896787466 +0100
|
||||
+++ serde_with-1.9.4/Cargo.toml 2021-08-11 09:55:10.604104850 +0100
|
||||
@@ -119,7 +119,6 @@
|
||||
|
||||
[features]
|
||||
chrono = ["chrono_crate"]
|
||||
-default = ["macros"]
|
||||
guide = ["doc-comment", "macros"]
|
||||
json = ["serde_json"]
|
||||
macros = ["serde_with_macros"]
|
Loading…
Reference in new issue