Initial import (#2183332)
parent
d13a4268df
commit
81bcdba8f5
@ -0,0 +1 @@
|
||||
/serde_spanned-0.6.1.crate
|
@ -0,0 +1,85 @@
|
||||
# Generated by rust2rpm 24
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate serde_spanned
|
||||
|
||||
Name: rust-serde_spanned
|
||||
Version: 0.6.1
|
||||
Release: %autorelease
|
||||
Summary: Serde-compatible spanned Value
|
||||
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/serde_spanned
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * fix copypasta in upstream crate description:
|
||||
# https://github.com/toml-rs/toml/pull/536
|
||||
Patch: serde_spanned-fix-metadata.diff
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Serde-compatible spanned Value.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+serde-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+serde-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "serde" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+serde-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
@ -0,0 +1,15 @@
|
||||
--- serde_spanned-0.6.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ serde_spanned-0.6.1/Cargo.toml 2023-03-30T21:13:30.708654+00:00
|
||||
@@ -23,11 +23,7 @@
|
||||
"benches/**/*",
|
||||
"tests/**/*",
|
||||
]
|
||||
-description = """
|
||||
-A native Rust encoder and decoder of TOML-formatted files and streams. Provides
|
||||
-implementations of the standard Serialize/Deserialize traits for TOML data to
|
||||
-facilitate deserializing and serializing Rust structures.
|
||||
-"""
|
||||
+description = "Serde-compatible spanned Value"
|
||||
homepage = "https://github.com/toml-rs/toml"
|
||||
documentation = "https://docs.rs/serde_spanned"
|
||||
readme = "README.md"
|
Loading…
Reference in new issue