initial import (#1795209)
parent
faadb23d15
commit
d1ebdfd669
@ -0,0 +1,4 @@
|
||||
/results_*
|
||||
/*.src.rpm
|
||||
|
||||
/serde_repr-0.1.5.crate
|
@ -0,0 +1,13 @@
|
||||
diff --git a/Cargo.toml b/Cargo.toml
|
||||
index cb4d121..6e96d91 100644
|
||||
--- a/Cargo.toml
|
||||
+++ b/Cargo.toml
|
||||
@@ -32,7 +32,7 @@ version = "1.0"
|
||||
[dependencies.syn]
|
||||
version = "1.0"
|
||||
[dev-dependencies.rustversion]
|
||||
-version = "0.1"
|
||||
+version = "1.0"
|
||||
|
||||
[dev-dependencies.serde]
|
||||
version = "1.0"
|
@ -0,0 +1,80 @@
|
||||
# Generated by rust2rpm 13
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate serde_repr
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.1.5
|
||||
Release: 1%{?dist}
|
||||
Summary: Derive Serialize and Deserialize for C-like enums
|
||||
|
||||
# Upstream license specification: MIT OR Apache-2.0
|
||||
License: MIT or ASL 2.0
|
||||
URL: https://crates.io/crates/serde_repr
|
||||
Source: %{crates_source}
|
||||
|
||||
# rustversion in fedora is too new (1.0), but seems to be compatible
|
||||
Patch0: 00-bump-rustversion-dep.patch
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
%if %{__cargo_skip_build}
|
||||
BuildArch: noarch
|
||||
%endif
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%global _description %{expand:
|
||||
Derive Serialize and Deserialize that delegates to the underlying repr of a
|
||||
C-like enum.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license LICENSE-APACHE LICENSE-MIT
|
||||
%doc README.md
|
||||
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "default" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 27 2020 Fabio Valentini <decathorpe@gmail.com> - 0.1.5-1
|
||||
- Initial package
|
||||
|
Loading…
Reference in new issue