initial import (#1959119)
parent
c663789b54
commit
33a61b6d72
@ -0,0 +1,4 @@
|
|||||||
|
/results_*/
|
||||||
|
/*.src.rpm
|
||||||
|
|
||||||
|
/serde_fmt-1.0.1.crate
|
@ -0,0 +1,90 @@
|
|||||||
|
# Generated by rust2rpm 17
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate serde_fmt
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 1.0.1
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Write any serde::Serialize using the standard formatting APIs
|
||||||
|
|
||||||
|
# Upstream license specification: Apache-2.0 OR MIT
|
||||||
|
License: ASL 2.0 or MIT
|
||||||
|
URL: https://crates.io/crates/serde_fmt
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Initial patched metadata
|
||||||
|
# * drop CI files that are only useful for upstream
|
||||||
|
Patch0: serde_fmt-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
%if %{__cargo_skip_build}
|
||||||
|
BuildArch: noarch
|
||||||
|
%endif
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Write any serde::Serialize using the standard formatting APIs.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE-APACHE LICENSE-MIT
|
||||||
|
%doc README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "default" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+std-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+std-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "std" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+std-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon May 10 2021 Fabio Valentini <decathorpe@gmail.com> - 1.0.1-1
|
||||||
|
- Initial package
|
@ -0,0 +1,11 @@
|
|||||||
|
--- serde_fmt-1.0.1/Cargo.toml 2020-05-22T04:26:16+00:00
|
||||||
|
+++ serde_fmt-1.0.1/Cargo.toml 2021-04-21T09:11:52.805519+00:00
|
||||||
|
@@ -15,7 +15,7 @@
|
||||||
|
name = "serde_fmt"
|
||||||
|
version = "1.0.1"
|
||||||
|
authors = ["Ashley Mannix <ashleymannix@live.com.au>"]
|
||||||
|
-exclude = [".travis.yml"]
|
||||||
|
+exclude = [".travis.yml", "ci"]
|
||||||
|
description = "Write any serde::Serialize using the standard formatting APIs"
|
||||||
|
documentation = "https://docs.rs/serde_fmt"
|
||||||
|
readme = "README.md"
|
Loading…
Reference in new issue