Initial import (#2138445)
parent
b22b69aad0
commit
a4fb974ccf
@ -0,0 +1 @@
|
|||||||
|
/sequoia-policy-config-0.3.0.crate
|
@ -1,3 +0,0 @@
|
|||||||
# rust-sequoia-policy-config
|
|
||||||
|
|
||||||
The rust-sequoia-policy-config package
|
|
@ -0,0 +1,73 @@
|
|||||||
|
# Generated by rust2rpm 23
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate sequoia-policy-config
|
||||||
|
|
||||||
|
Name: rust-sequoia-policy-config
|
||||||
|
Version: 0.3.0
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Configure Sequoia using a configuration file
|
||||||
|
|
||||||
|
License: LGPL-2.0-or-later
|
||||||
|
URL: https://crates.io/crates/sequoia-policy-config
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Automatically generated patch to strip foreign dependencies
|
||||||
|
Patch: sequoia-policy-config-fix-metadata-auto.diff
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * default to the nettle crypto backend of sequoia-openpgp
|
||||||
|
Patch: sequoia-policy-config-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 21
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Configure Sequoia using a configuration file.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE.txt
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
@ -0,0 +1,13 @@
|
|||||||
|
--- sequoia-policy-config-0.3.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ sequoia-policy-config-0.3.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
@@ -55,10 +55,5 @@
|
||||||
|
features = ["crypto-nettle"]
|
||||||
|
default-features = false
|
||||||
|
|
||||||
|
-[target."cfg(windows)".dev-dependencies.sequoia-openpgp]
|
||||||
|
-version = "1"
|
||||||
|
-features = ["crypto-cng"]
|
||||||
|
-default-features = false
|
||||||
|
-
|
||||||
|
[badges.maintenance]
|
||||||
|
status = "actively-developed"
|
@ -0,0 +1,10 @@
|
|||||||
|
--- sequoia-policy-config-0.3.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ sequoia-policy-config-0.3.0/Cargo.toml 2022-10-28T20:32:52.040456+00:00
|
||||||
|
@@ -36,6 +36,7 @@
|
||||||
|
|
||||||
|
[dependencies.sequoia-openpgp]
|
||||||
|
version = "1"
|
||||||
|
+features = ["crypto-nettle"]
|
||||||
|
default-features = false
|
||||||
|
|
||||||
|
[dependencies.serde]
|
Loading…
Reference in new issue