Update to version 1.16.0; Fixes RHBZ#2207606

epel9
Fabio Valentini 2 years ago
parent 44df934738
commit af5403cb19
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -11,3 +11,4 @@
/sequoia-openpgp-1.13.0.crate /sequoia-openpgp-1.13.0.crate
/sequoia-openpgp-1.14.0.crate /sequoia-openpgp-1.14.0.crate
/sequoia-openpgp-1.15.0.crate /sequoia-openpgp-1.15.0.crate
/sequoia-openpgp-1.16.0.crate

@ -5,7 +5,7 @@
%global crate sequoia-openpgp %global crate sequoia-openpgp
Name: rust-sequoia-openpgp Name: rust-sequoia-openpgp
Version: 1.15.0 Version: 1.16.0
Release: %autorelease Release: %autorelease
Summary: OpenPGP data types and associated machinery Summary: OpenPGP data types and associated machinery
@ -17,7 +17,7 @@ Patch: sequoia-openpgp-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes # Manually created patch for downstream crate metadata changes
# * drop feature for Windows-specific crypto backend # * drop feature for Windows-specific crypto backend
# * drop unused, benchmark-only criterion dev-dependency to speed up builds # * drop unused, benchmark-only criterion dev-dependency to speed up builds
# * drop example-only rpassword dev-dependency (currently too old in EPEL 9) # * bump rpassword dev-dependency from 6 to 7
Patch: sequoia-openpgp-fix-metadata.diff Patch: sequoia-openpgp-fix-metadata.diff
BuildRequires: rust-packaging >= 21 BuildRequires: rust-packaging >= 21
@ -211,8 +211,6 @@ use the "openssl-sys" feature of the "%{crate}" crate.
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
# remove examples which depend on rpassword
rm examples/{notarize.rs,sign.rs,sign-detached.rs}
%cargo_prep %cargo_prep
%generate_buildrequires %generate_buildrequires

@ -30,4 +30,5 @@ unwanted-features =
typenum typenum
x25519-dalek-ng x25519-dalek-ng
crypto-botan crypto-botan
crypto-botan2
crypto-rust crypto-rust

@ -1,6 +1,6 @@
--- sequoia-openpgp-1.15.0/Cargo.toml 1970-01-01T00:00:01+00:00 --- sequoia-openpgp-1.16.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ sequoia-openpgp-1.15.0/Cargo.toml 2023-05-06T19:43:47.023678+00:00 +++ sequoia-openpgp-1.16.0/Cargo.toml 2023-05-17T13:48:32.634394+00:00
@@ -302,8 +302,6 @@ @@ -303,8 +303,6 @@
crypto-cng = [ crypto-cng = [
"cipher", "cipher",
"eax", "eax",
@ -9,7 +9,7 @@
"ed25519-dalek", "ed25519-dalek",
"num-bigint-dig", "num-bigint-dig",
] ]
@@ -348,37 +346,6 @@ @@ -349,37 +347,6 @@
"crypto-nettle", "crypto-nettle",
] ]

@ -1,6 +1,6 @@
--- sequoia-openpgp-1.15.0/Cargo.toml 1970-01-01T00:00:01+00:00 --- sequoia-openpgp-1.16.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ sequoia-openpgp-1.15.0/Cargo.toml 2023-05-06T19:44:10.852727+00:00 +++ sequoia-openpgp-1.16.0/Cargo.toml 2023-05-17T13:49:16.702593+00:00
@@ -264,19 +264,12 @@ @@ -264,10 +264,6 @@
version = "0.8" version = "0.8"
features = ["xxh3"] features = ["xxh3"]
@ -11,19 +11,19 @@
[dev-dependencies.quickcheck] [dev-dependencies.quickcheck]
version = "1" version = "1"
default-features = false default-features = false
@@ -276,7 +272,7 @@
[dev-dependencies.rand]
version = "0.8" version = "0.8"
-
-[dev-dependencies.rpassword] [dev-dependencies.rpassword]
-version = "6.0" -version = "6.0"
+version = "7.0"
[build-dependencies.lalrpop] [build-dependencies.lalrpop]
version = ">=0.17, <0.20" version = ">=0.17, <0.20"
@@ -299,12 +292,6 @@ @@ -300,12 +296,6 @@
"buffered-reader/compression-deflate",
] ]
crypto-botan = ["botan"] crypto-botan = ["botan/botan3"]
crypto-botan2 = ["botan"]
-crypto-cng = [ -crypto-cng = [
- "cipher", - "cipher",
- "eax", - "eax",

@ -1 +1 @@
SHA512 (sequoia-openpgp-1.15.0.crate) = 01603db1706c266eb1a66132de17936be3ab38bbdff958edf8f97d7b8bbde9ac82b16f324ae442241380cf6f82d9369463591c16b34cfc7938395a55ccef865e SHA512 (sequoia-openpgp-1.16.0.crate) = 0f51a494b8c011b77e98adef1747ba84eb36bf1b629c02341c10cf33b86cc2a7da9a99f57b65f44f23f8a2969fc83a1326288133b904ee5ebf54078034f6d5fc

Loading…
Cancel
Save