parent
0bb1e061c9
commit
7d6a598539
@ -1,35 +0,0 @@
|
||||
[DEFAULT]
|
||||
unwanted-features =
|
||||
aes
|
||||
block-padding
|
||||
blowfish
|
||||
botan
|
||||
cast5
|
||||
cfb-mode
|
||||
cipher
|
||||
des
|
||||
digest
|
||||
eax
|
||||
ecb
|
||||
ecdsa
|
||||
ed25519
|
||||
ed25519-dalek
|
||||
generic-array
|
||||
idea
|
||||
md-5
|
||||
num-bigint-dig
|
||||
p256
|
||||
rand07
|
||||
rand
|
||||
rand_core
|
||||
ripemd
|
||||
rsa
|
||||
sha-1
|
||||
sha2
|
||||
twofish
|
||||
typenum
|
||||
x25519-dalek-ng
|
||||
crypto-botan
|
||||
crypto-botan2
|
||||
crypto-cng
|
||||
crypto-rust
|
@ -0,0 +1,39 @@
|
||||
[features]
|
||||
hide = [
|
||||
# optional dependencies
|
||||
"aes",
|
||||
"aes-gcm",
|
||||
"block-padding",
|
||||
"blowfish",
|
||||
"botan",
|
||||
"camellia",
|
||||
"cast5",
|
||||
"cfb-mode",
|
||||
"cipher",
|
||||
"des",
|
||||
"digest",
|
||||
"dsa",
|
||||
"eax",
|
||||
"ecb",
|
||||
"ecdsa",
|
||||
"ed25519",
|
||||
"ed25519-dalek",
|
||||
"idea",
|
||||
"md-5",
|
||||
"num-bigint-dig",
|
||||
"p256",
|
||||
"rand_core",
|
||||
"ripemd",
|
||||
"rsa",
|
||||
"sha2",
|
||||
"twofish",
|
||||
"typenum",
|
||||
"x25519-dalek",
|
||||
# features
|
||||
"crypto-botan",
|
||||
"crypto-botan2",
|
||||
"crypto-cng",
|
||||
"crypto-fuzzing",
|
||||
"crypto-rust",
|
||||
]
|
||||
|
@ -1,22 +1,22 @@
|
||||
--- sequoia-openpgp-1.16.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ sequoia-openpgp-1.16.1/Cargo.toml 2023-09-26T17:19:35.531001+00:00
|
||||
@@ -264,10 +264,6 @@
|
||||
--- sequoia-openpgp-1.17.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ sequoia-openpgp-1.17.0/Cargo.toml 2023-11-02T16:07:42.232894+00:00
|
||||
@@ -277,10 +277,6 @@
|
||||
[dependencies.xxhash-rust]
|
||||
version = "0.8"
|
||||
features = ["xxh3"]
|
||||
|
||||
-
|
||||
-[dev-dependencies.criterion]
|
||||
-version = "0.4"
|
||||
-version = "0.5"
|
||||
-features = ["html_reports"]
|
||||
-
|
||||
|
||||
[dev-dependencies.quickcheck]
|
||||
version = "1"
|
||||
default-features = false
|
||||
@@ -276,7 +272,7 @@
|
||||
version = "0.8"
|
||||
|
||||
[dev-dependencies.rpassword]
|
||||
-version = "6.0"
|
||||
+version = "7.0"
|
||||
|
||||
[build-dependencies.lalrpop]
|
||||
version = ">=0.17, <0.20"
|
||||
@@ -346,8 +342,6 @@
|
||||
"ripemd",
|
||||
"rsa",
|
||||
"sha2",
|
||||
- "sha1collisiondetection/digest-trait",
|
||||
- "sha1collisiondetection/oid",
|
||||
"twofish",
|
||||
"typenum",
|
||||
"x25519-dalek",
|
||||
|
@ -1 +1 @@
|
||||
SHA512 (sequoia-openpgp-1.16.1.crate) = c12b0bdacfc120f51f02d05029627b81c9d3be3a7297763a378c472560a5b81d1a46c3bd2acf5482c8147e1cc1f247cf0afeac735d786a77c32eeaa8e624e914
|
||||
SHA512 (sequoia-openpgp-1.17.0.crate) = 275d0e393befc19e8b9a70f7e931d8f95f093a2f4734e8ff2543176b1c38b7d9e07e95bf474df0a1784d210baadfcc4f3de689e5061818ca3a22d604f52f6cba
|
||||
|
Loading…
Reference in new issue