Update to version 1.15.0; Fixes RHBZ#2193409

epel9
Fabio Valentini 2 years ago
parent 3b71b74764
commit 44df934738
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -10,3 +10,4 @@
/sequoia-openpgp-1.12.0.crate
/sequoia-openpgp-1.13.0.crate
/sequoia-openpgp-1.14.0.crate
/sequoia-openpgp-1.15.0.crate

@ -1,36 +0,0 @@
From aacdf9b232c383693fa0c6d9411d3ec168b9487a Mon Sep 17 00:00:00 2001
From: Wiktor Kwapisiewicz <wiktor@metacode.biz>
Date: Thu, 19 Jan 2023 09:55:34 +0100
Subject: [PATCH] Fix EC curve detection.
- Some systems have smaller set of supported curves and even though the
curve identifiers are compiled in the usage of the curve fails.
- Try to construct an `EcGroup` using retrieved `Nid` as this is a cheap
check that will fail if the curve is truly unsupported.
- Fixes #976.
---
src/crypto/backend/openssl.rs | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/src/crypto/backend/openssl.rs b/src/crypto/backend/openssl.rs
index 4e610bfe8..aa5c9db7d 100644
--- a/src/crypto/backend/openssl.rs
+++ b/src/crypto/backend/openssl.rs
@@ -43,7 +43,11 @@ impl Curve {
} else {
// the rest of EC algorithms are supported via the same
// codepath
- openssl::nid::Nid::try_from(self).is_ok()
+ if let Ok(nid) = openssl::nid::Nid::try_from(self) {
+ openssl::ec::EcGroup::from_curve_name(nid).is_ok()
+ } else {
+ false
+ }
}
}
}
--
GitLab

@ -5,7 +5,7 @@
%global crate sequoia-openpgp
Name: rust-sequoia-openpgp
Version: 1.14.0
Version: 1.15.0
Release: %autorelease
Summary: OpenPGP data types and associated machinery
@ -17,7 +17,7 @@ Patch: sequoia-openpgp-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * drop feature for Windows-specific crypto backend
# * drop unused, benchmark-only criterion dev-dependency to speed up builds
# * drop example-only rpassword dev-dependency (currently too old in Fedora)
# * drop example-only rpassword dev-dependency (currently too old in EPEL 9)
Patch: sequoia-openpgp-fix-metadata.diff
BuildRequires: rust-packaging >= 21
@ -173,18 +173,6 @@ use the "flate2" feature of the "%{crate}" crate.
%files -n %{name}+flate2-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+foreign-types-shared-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+foreign-types-shared-devel %{_description}
This package contains library source intended for building other packages which
use the "foreign-types-shared" feature of the "%{crate}" crate.
%files -n %{name}+foreign-types-shared-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+nettle-devel
Summary: %{summary}
BuildArch: noarch
@ -242,9 +230,7 @@ rm examples/{notarize.rs,sign.rs,sign-detached.rs}
# * run tests with nettle crypto backend (default)
%cargo_test -n -f crypto-nettle,compression
# * run tests with openssl crypto backend
# * skip test that fails with OpenSSL < 3.0.7 due to missing RIPEMD160 algorithm:
# https://gitlab.com/sequoia-pgp/sequoia/-/issues/979
%cargo_test -n -f crypto-openssl,compression -- -- --skip packet::one_pass_sig::tests::roundtrip
%cargo_test -n -f crypto-openssl,compression
%endif
%changelog

@ -1,16 +1,18 @@
[DEFAULT]
unwanted-features =
aes
block-modes
block-padding
blowfish
botan
cast5
cfb-mode
cipher
des
digest
eax
ecb
ecdsa
ed25519
ed25519-dalek
generic-array
idea
@ -18,13 +20,14 @@ unwanted-features =
num-bigint-dig
p256
rand07
rand
rand_core
ripemd160
ripemd
rsa
sha-1
sha2
twofish
typenum
x25519-dalek
x25519-dalek-ng
crypto-botan
crypto-rust

@ -1,15 +1,15 @@
--- sequoia-openpgp-1.14.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ sequoia-openpgp-1.14.0/Cargo.toml 2023-03-25T21:39:42.452829+00:00
@@ -286,8 +286,6 @@
crypto-botan = ["botan"]
--- sequoia-openpgp-1.15.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ sequoia-openpgp-1.15.0/Cargo.toml 2023-05-06T19:43:47.023678+00:00
@@ -302,8 +302,6 @@
crypto-cng = [
"cipher",
"eax",
- "winapi",
- "win-crypto-ng",
"ed25519-dalek",
"num-bigint-dig",
]
@@ -330,37 +328,6 @@
@@ -348,37 +346,6 @@
"crypto-nettle",
]
@ -31,7 +31,7 @@
-package = "rand"
-
-[target."cfg(windows)".dependencies.win-crypto-ng]
-version = "0.4"
-version = ">=0.4, <0.6"
-features = [
- "rand",
- "block-cipher",

@ -1,11 +1,11 @@
--- sequoia-openpgp-1.14.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ sequoia-openpgp-1.14.0/Cargo.toml 2023-03-25T21:41:01.746107+00:00
@@ -249,19 +249,12 @@
--- sequoia-openpgp-1.15.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ sequoia-openpgp-1.15.0/Cargo.toml 2023-05-06T19:44:10.852727+00:00
@@ -264,19 +264,12 @@
version = "0.8"
features = ["xxh3"]
-[dev-dependencies.criterion]
-version = "0.3.4"
-version = "0.4"
-features = ["html_reports"]
-
[dev-dependencies.quickcheck]
@ -19,12 +19,13 @@
-version = "6.0"
[build-dependencies.lalrpop]
version = ">=0.17"
@@ -284,11 +277,6 @@
version = ">=0.17, <0.20"
@@ -299,12 +292,6 @@
"buffered-reader/compression-deflate",
]
crypto-botan = ["botan"]
-crypto-cng = [
- "cipher",
- "eax",
- "ed25519-dalek",
- "num-bigint-dig",

@ -1 +1 @@
SHA512 (sequoia-openpgp-1.14.0.crate) = aad9d82eb8e589c241eeb7155549294116f35d4790a15740273247a8f1366db4fbdf123dccdc2a4b6bb5b5658ad5925698b30538a8668330d9970b89701a7765
SHA512 (sequoia-openpgp-1.15.0.crate) = 01603db1706c266eb1a66132de17936be3ab38bbdff958edf8f97d7b8bbde9ac82b16f324ae442241380cf6f82d9369463591c16b34cfc7938395a55ccef865e

Loading…
Cancel
Save