initial import (#1948158)
parent
b5482cfbb2
commit
e2b7b9f4d6
@ -0,0 +1,4 @@
|
||||
/results_*/
|
||||
/*.src.rpm
|
||||
|
||||
/sequoia-net-0.23.0.crate
|
@ -0,0 +1,3 @@
|
||||
[DEFAULT]
|
||||
unwanted-features =
|
||||
crypto-cng
|
@ -0,0 +1,126 @@
|
||||
# Generated by rust2rpm 16
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate sequoia-net
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.23.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Network services for OpenPGP
|
||||
|
||||
# Upstream license specification: GPL-2.0-or-later
|
||||
# https://gitlab.com/sequoia-pgp/sequoia/-/issues/708
|
||||
License: GPLv2+
|
||||
URL: https://crates.io/crates/sequoia-net
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
# * don't drop default features from rand dev-dependency
|
||||
Patch0: sequoia-net-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
%if %{__cargo_skip_build}
|
||||
BuildArch: noarch
|
||||
%endif
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%global _description %{expand:
|
||||
Network services for OpenPGP.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%doc README.md
|
||||
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "default" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+compression-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+compression-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "compression" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+compression-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+compression-bzip2-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+compression-bzip2-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "compression-bzip2" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+compression-bzip2-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+compression-deflate-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+compression-deflate-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "compression-deflate" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+compression-deflate-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+crypto-nettle-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+crypto-nettle-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "crypto-nettle" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+crypto-nettle-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Thu Apr 08 2021 Fabio Valentini <decathorpe@gmail.com> - 0.23.0-1
|
||||
- Initial package
|
@ -0,0 +1,10 @@
|
||||
--- sequoia-net-0.23.0/Cargo.toml 2021-01-21T13:57:56+00:00
|
||||
+++ sequoia-net-0.23.0/Cargo.toml 2021-04-07T11:42:11.498117+00:00
|
||||
@@ -64,7 +64,6 @@
|
||||
version = "0.1.2"
|
||||
[dev-dependencies.rand]
|
||||
version = "0.7"
|
||||
-default-features = false
|
||||
|
||||
[dev-dependencies.tokio]
|
||||
version = "0.2.19"
|
Loading…
Reference in new issue