Update to version 0.27.0; Fixes RHBZ#2107108

epel9
Fabio Valentini 2 years ago
parent 2c9d18783f
commit c87576f74d
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -3,3 +3,4 @@
/sequoia-net-0.23.0.crate /sequoia-net-0.23.0.crate
/sequoia-net-0.24.0.crate /sequoia-net-0.24.0.crate
/sequoia-net-0.27.0.crate

@ -1,3 +0,0 @@
[DEFAULT]
unwanted-features =
crypto-cng

@ -1,23 +1,22 @@
# Generated by rust2rpm 21 # Generated by rust2rpm 24
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate sequoia-net %global crate sequoia-net
Name: rust-%{crate} Name: rust-sequoia-net
Version: 0.24.0 Version: 0.27.0
Release: %autorelease Release: %autorelease
Summary: Network services for OpenPGP Summary: Network services for OpenPGP
# Upstream license specification: LGPL-2.0-or-later License: LGPL-2.0-or-later
License: LGPLv2+
URL: https://crates.io/crates/sequoia-net URL: https://crates.io/crates/sequoia-net
Source: %{crates_source} Source: %{crates_source}
# Initial patched metadata # Automatically generated patch to strip foreign dependencies
Patch: sequoia-net-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * don't drop default features from rand dev-dependency # * don't drop default features from rand dev-dependency
Patch0: sequoia-net-fix-metadata.diff Patch: sequoia-net-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging >= 21 BuildRequires: rust-packaging >= 21
@ -52,54 +51,6 @@ use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+compression-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+compression-devel %{_description}
This package contains library source intended for building other packages which
use the "compression" feature of the "%{crate}" crate.
%files -n %{name}+compression-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+compression-bzip2-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+compression-bzip2-devel %{_description}
This package contains library source intended for building other packages which
use the "compression-bzip2" feature of the "%{crate}" crate.
%files -n %{name}+compression-bzip2-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+compression-deflate-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+compression-deflate-devel %{_description}
This package contains library source intended for building other packages which
use the "compression-deflate" feature of the "%{crate}" crate.
%files -n %{name}+compression-deflate-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+crypto-nettle-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+crypto-nettle-devel %{_description}
This package contains library source intended for building other packages which
use the "crypto-nettle" feature of the "%{crate}" crate.
%files -n %{name}+crypto-nettle-devel
%ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep %cargo_prep
@ -108,14 +59,14 @@ use the "crypto-nettle" feature of the "%{crate}" crate.
%cargo_generate_buildrequires %cargo_generate_buildrequires
%build %build
%cargo_build %cargo_build -f sequoia-openpgp/crypto-nettle
%install %install
%cargo_install %cargo_install
%if %{with check} %if %{with check}
%check %check
%cargo_test %cargo_test -f sequoia-openpgp/crypto-nettle
%endif %endif
%changelog %changelog

@ -0,0 +1,17 @@
--- sequoia-net-0.27.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ sequoia-net-0.27.0/Cargo.toml 2023-04-14T09:33:37.611489+00:00
@@ -120,14 +120,6 @@
]
default-features = false
-[target."cfg(windows)".dev-dependencies.sequoia-openpgp]
-version = "1"
-features = [
- "crypto-cng",
- "__implicit-crypto-backend-for-tests",
-]
-default-features = false
-
[badges.gitlab]
repository = "sequoia-pgp/sequoia"

@ -1,10 +1,10 @@
--- sequoia-net-0.24.0/Cargo.toml 1970-01-01T00:00:01+00:00 --- sequoia-net-0.27.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ sequoia-net-0.24.0/Cargo.toml 2022-03-16T10:56:55.150026+00:00 +++ sequoia-net-0.27.0/Cargo.toml 2023-04-14T09:33:41.882504+00:00
@@ -79,7 +79,6 @@ @@ -110,7 +110,6 @@
[dev-dependencies.rand] [dev-dependencies.rand]
version = "0.7" version = "0.8"
features = ["getrandom"] features = ["getrandom"]
-default-features = false -default-features = false
[features] [target."cfg(not(windows))".dev-dependencies.sequoia-openpgp]
compression = ["sequoia-openpgp/compression"] version = "1"

@ -1 +1 @@
SHA512 (sequoia-net-0.24.0.crate) = 4171321068894fa7f322d73eb6d0094cffd7bbeff4d810756eacbf4eff7bd43389f50dc1b26fbd697ae78c7c65723b79b5831f0e14a8ce6f67079f12f1c5b5c2 SHA512 (sequoia-net-0.27.0.crate) = 71682e405262b0298a4d97aa6c2cecea4bc6b44927265f0ac252fe367cb51c11943d95bc84152b1d749c69e345bdff8129dd88e7960b4919886a8e3f4c043cff

Loading…
Cancel
Save