Update to version 1.0.1; Fixes RHBZ#2168872

epel9
Fabio Valentini 2 years ago
parent 43dfc9d126
commit dad31b39ca
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -3,3 +3,4 @@
/sequoia-keyring-linter-0.5.0.crate /sequoia-keyring-linter-0.5.0.crate
/sequoia-keyring-linter-1.0.0.crate /sequoia-keyring-linter-1.0.0.crate
/sequoia-keyring-linter-1.0.1.crate

@ -0,0 +1,49 @@
From e9d23df093643add12c83572e6b66bc38346ea08 Mon Sep 17 00:00:00 2001
From: Fabio Valentini <decathorpe@gmail.com>
Date: Fri, 14 Apr 2023 14:09:51 +0200
Subject: [PATCH] build: fix file names for generated manpage and shell
completions
---
build.rs | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/build.rs b/build.rs
index 818e5bb..6d8da89 100644
--- a/build.rs
+++ b/build.rs
@@ -24,7 +24,7 @@ fn build_man_pages() -> io::Result<()> {
let mut buffer: Vec<u8> = Default::default();
man.render(&mut buffer)?;
- let filename = out_dir.join("sq-wot.1");
+ let filename = out_dir.join("sq-keyring-linter.1");
println!("cargo:warning=writing man page to {}", filename.display());
std::fs::write(filename, buffer)?;
@@ -33,7 +33,7 @@ fn build_man_pages() -> io::Result<()> {
let mut buffer: Vec<u8> = Default::default();
man.render(&mut buffer)?;
- let filename = out_dir.join(format!("sq-wot-{}.1", sc.get_name()));
+ let filename = out_dir.join(format!("sq-keyring-linter-{}.1", sc.get_name()));
println!("cargo:warning=writing man page to {}", filename.display());
std::fs::write(filename, buffer)?;
}
@@ -49,11 +49,11 @@ fn build_shell_completions() -> io::Result<()> {
use clap::CommandFactory;
- let mut sq_wot = cli::Linter::command();
+ let mut sq_linter = cli::Linter::command();
for shell in &[Shell::Bash, Shell::Fish, Shell::Zsh, Shell::PowerShell,
Shell::Elvish] {
let path = clap_complete::generate_to(
- *shell, &mut sq_wot, "sq-wot", &out_dir)
+ *shell, &mut sq_linter, "sq-keyring-linter", &out_dir)
.unwrap();
println!("cargo:warning=completion file is generated: {:?}", path);
};
--
2.40.0

@ -1,10 +1,10 @@
# Generated by rust2rpm 23 # Generated by rust2rpm 24
%bcond_without check %bcond_without check
%global crate sequoia-keyring-linter %global crate sequoia-keyring-linter
Name: rust-sequoia-keyring-linter Name: rust-sequoia-keyring-linter
Version: 1.0.0 Version: 1.0.1
Release: %autorelease Release: %autorelease
Summary: Linter for keyrings Summary: Linter for keyrings
@ -13,15 +13,17 @@ URL: https://crates.io/crates/sequoia-keyring-linter
Source: %{crates_source} Source: %{crates_source}
# Manually created patch for downstream crate metadata changes # Manually created patch for downstream crate metadata changes
# * exclude files that are only useful for upstream development # * exclude files that are only useful for upstream development
# * prevent manpages from getting installed twice # * bump rpassword dependency from 6 to 7
# * bump assert_cmd to 2.0.0 # * bump assert_cmd dev-dependency from 1.0.1 to 2.0.0
# * remove feature for Windows-specific cryptography # * remove feature for Windows-specific cryptography
Patch: sequoia-keyring-linter-fix-metadata.diff Patch: sequoia-keyring-linter-fix-metadata.diff
# https://gitlab.com/sequoia-pgp/keyring-linter/-/merge_requests/9
Patch: 0001-build-fix-file-names-for-generated-manpage-and-shell.patch
BuildRequires: rust-packaging >= 21 BuildRequires: rust-packaging >= 23
%global _description %{expand: %global _description %{expand:
Linter for keyrings.} A linter for keyrings.}
%description %{_description} %description %{_description}
@ -29,7 +31,9 @@ Linter for keyrings.}
Summary: %{summary} Summary: %{summary}
# (MIT OR Apache-2.0) AND Unicode-DFS-2016 # (MIT OR Apache-2.0) AND Unicode-DFS-2016
# Apache-2.0 # Apache-2.0
# Apache-2.0 AND MIT
# Apache-2.0 OR MIT # Apache-2.0 OR MIT
# Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT
# BSL-1.0 # BSL-1.0
# GPL-2.0-or-later # GPL-2.0-or-later
# LGPL-2.0-or-later # LGPL-2.0-or-later
@ -39,18 +43,20 @@ Summary: %{summary}
# MIT OR Apache-2.0 OR Zlib # MIT OR Apache-2.0 OR Zlib
# Unlicense OR MIT # Unlicense OR MIT
# Zlib OR Apache-2.0 OR MIT # Zlib OR Apache-2.0 OR MIT
License: GPL-2.0 AND Apache-2.0 AND BSL-1.0 AND MIT AND Unicode-DFS-2016 License: GPL-2.0-or-later AND Apache-2.0 AND BSL-1.0 AND LGPL-2.0-or-later AND MIT AND Unicode-DFS-2016 AND (Apache-2.0 OR MIT) AND (Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT) AND (LGPL-3.0 OR GPL-2.0 OR GPL-3.0) AND (MIT OR Apache-2.0 OR Zlib) AND (Unlicense OR MIT)
# LICENSE.dependencies contains a full license breakdown
%description -n %{crate} %{_description} %description -n %{crate} %{_description}
%files -n %{crate} %files -n %{crate}
%license LICENSE.txt %license LICENSE.txt
%if 0%{?rhel} > 9
%license LICENSE.dependencies %license LICENSE.dependencies
%endif
%doc README.md %doc README.md
%{_bindir}/sq-keyring-linter %{_bindir}/sq-keyring-linter
%{_mandir}/man1/sq-keyring-linter* %{_mandir}/man1/sq-keyring-linter*
%{bash_completions_dir}/sq-keyring-linter.bash
%{fish_completions_dir}/sq-keyring-linter.fish
%{zsh_completions_dir}/_sq-keyring-linter
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
@ -61,20 +67,25 @@ License: GPL-2.0 AND Apache-2.0 AND BSL-1.0 AND MIT AND Unicode-DFS-2016
%build %build
%cargo_build %cargo_build
%if 0%{?rhel} > 9 %cargo_license_summary
%{cargo_license} > LICENSE.dependencies %{cargo_license} > LICENSE.dependencies
%endif
%install %install
%cargo_install %cargo_install
# install manual pages # install manual pages
mkdir -p %{buildroot}/%{_mandir}/man1 install -Dpm 0644 target/release/build/%{crate}-*/out/sq-keyring-linter.1 \
cp -pav sq-keyring-linter.1 %{buildroot}/%{_mandir}/man1/ %{buildroot}/%{_mandir}/man1/sq-keyring-linter.1
# install shell completions
install -Dpm 0644 target/release/build/%{crate}-*/out/sq-keyring-linter.bash \
%{buildroot}/%{bash_completions_dir}/sq-keyring-linter.bash
install -Dpm 0644 target/release/build/%{crate}-*/out/sq-keyring-linter.fish \
%{buildroot}/%{fish_completions_dir}/sq-keyring-linter.fish
install -Dpm 0644 target/release/build/%{crate}-*/out/_sq-keyring-linter \
%{buildroot}/%{zsh_completions_dir}/_sq-keyring-linter
%if %{with check} %if %{with check}
%check %check
# * skip a test that should fail but unexpectedly succeeds %cargo_test
%cargo_test -- -- --skip integration::sha1_authentication_subkey
%endif %endif
%changelog %changelog

@ -1,17 +1,26 @@
--- sequoia-keyring-linter-1.0.0/Cargo.toml 1970-01-01T00:00:01+00:00 --- sequoia-keyring-linter-1.0.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ sequoia-keyring-linter-1.0.0/Cargo.toml 2023-01-11T20:53:38.572348+00:00 +++ sequoia-keyring-linter-1.0.1/Cargo.toml 2023-04-14T11:43:19.210639+00:00
@@ -30,6 +30,10 @@ @@ -32,6 +32,10 @@
]
license = "GPL-2.0-or-later" license = "GPL-2.0-or-later"
repository = "https://gitlab.com/sequoia-pgp/keyring-linter" repository = "https://gitlab.com/sequoia-pgp/keyring-linter"
resolver = "2"
+exclude = [ +exclude = [
+ "Makefile", + "/Makefile",
+ "sq-keyring-linter.1", + "/sq-keyring-linter.1",
+] +]
[[bin]] [[bin]]
name = "sq-keyring-linter" name = "sq-keyring-linter"
@@ -58,13 +62,12 @@ @@ -57,7 +61,7 @@
]
[dependencies.rpassword]
-version = "6.0"
+version = "7.0"
[dependencies.sequoia-openpgp]
version = "1.0"
@@ -67,7 +71,7 @@
version = "1" version = "1"
[dev-dependencies.assert_cmd] [dev-dependencies.assert_cmd]
@ -20,6 +29,8 @@
[dev-dependencies.predicates] [dev-dependencies.predicates]
version = "1.0.5" version = "1.0.5"
@@ -89,7 +93,6 @@
version = "0.2"
[features] [features]
-crypto-cng = ["sequoia-openpgp/crypto-cng"] -crypto-cng = ["sequoia-openpgp/crypto-cng"]

@ -1 +1 @@
SHA512 (sequoia-keyring-linter-1.0.0.crate) = e97396ff0c0a713dfe49c8b0b16166658f56df0c2fd2516f01fee0c1abff052cf15f9ce3b24955b3738bd68d2b550c3232d01563e4d54c8eb1aa90f1c87e07a2 SHA512 (sequoia-keyring-linter-1.0.1.crate) = d1ed7d1ea9b39436a1a3f3b2fe192679dff5b8b4552f9768900f9a1ef9a72dd8b9522bf21ef176c1bb68c5feccd39c582e6ac355cd138351f2e938e6b51a30fe

Loading…
Cancel
Save