i9ce
changed/i9ce/rust-sequoia-keyring-linter-1.0.1-2.el9
commit
08212e6920
@ -0,0 +1,49 @@
|
|||||||
|
From e9d23df093643add12c83572e6b66bc38346ea08 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Fabio Valentini <decathorpe@gmail.com>
|
||||||
|
Date: Fri, 14 Apr 2023 14:09:51 +0200
|
||||||
|
Subject: [PATCH] build: fix file names for generated manpage and shell
|
||||||
|
completions
|
||||||
|
|
||||||
|
---
|
||||||
|
build.rs | 8 ++++----
|
||||||
|
1 file changed, 4 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/build.rs b/build.rs
|
||||||
|
index 818e5bb..6d8da89 100644
|
||||||
|
--- a/build.rs
|
||||||
|
+++ b/build.rs
|
||||||
|
@@ -24,7 +24,7 @@ fn build_man_pages() -> io::Result<()> {
|
||||||
|
let mut buffer: Vec<u8> = Default::default();
|
||||||
|
man.render(&mut buffer)?;
|
||||||
|
|
||||||
|
- let filename = out_dir.join("sq-wot.1");
|
||||||
|
+ let filename = out_dir.join("sq-keyring-linter.1");
|
||||||
|
println!("cargo:warning=writing man page to {}", filename.display());
|
||||||
|
std::fs::write(filename, buffer)?;
|
||||||
|
|
||||||
|
@@ -33,7 +33,7 @@ fn build_man_pages() -> io::Result<()> {
|
||||||
|
let mut buffer: Vec<u8> = Default::default();
|
||||||
|
man.render(&mut buffer)?;
|
||||||
|
|
||||||
|
- let filename = out_dir.join(format!("sq-wot-{}.1", sc.get_name()));
|
||||||
|
+ let filename = out_dir.join(format!("sq-keyring-linter-{}.1", sc.get_name()));
|
||||||
|
println!("cargo:warning=writing man page to {}", filename.display());
|
||||||
|
std::fs::write(filename, buffer)?;
|
||||||
|
}
|
||||||
|
@@ -49,11 +49,11 @@ fn build_shell_completions() -> io::Result<()> {
|
||||||
|
|
||||||
|
use clap::CommandFactory;
|
||||||
|
|
||||||
|
- let mut sq_wot = cli::Linter::command();
|
||||||
|
+ let mut sq_linter = cli::Linter::command();
|
||||||
|
for shell in &[Shell::Bash, Shell::Fish, Shell::Zsh, Shell::PowerShell,
|
||||||
|
Shell::Elvish] {
|
||||||
|
let path = clap_complete::generate_to(
|
||||||
|
- *shell, &mut sq_wot, "sq-wot", &out_dir)
|
||||||
|
+ *shell, &mut sq_linter, "sq-keyring-linter", &out_dir)
|
||||||
|
.unwrap();
|
||||||
|
println!("cargo:warning=completion file is generated: {:?}", path);
|
||||||
|
};
|
||||||
|
--
|
||||||
|
2.40.0
|
||||||
|
|
Binary file not shown.
@ -0,0 +1,39 @@
|
|||||||
|
--- sequoia-keyring-linter-1.0.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ sequoia-keyring-linter-1.0.1/Cargo.toml 2023-04-14T11:43:19.210639+00:00
|
||||||
|
@@ -32,6 +32,10 @@
|
||||||
|
license = "GPL-2.0-or-later"
|
||||||
|
repository = "https://gitlab.com/sequoia-pgp/keyring-linter"
|
||||||
|
resolver = "2"
|
||||||
|
+exclude = [
|
||||||
|
+ "/Makefile",
|
||||||
|
+ "/sq-keyring-linter.1",
|
||||||
|
+]
|
||||||
|
|
||||||
|
[[bin]]
|
||||||
|
name = "sq-keyring-linter"
|
||||||
|
@@ -57,7 +61,7 @@
|
||||||
|
]
|
||||||
|
|
||||||
|
[dependencies.rpassword]
|
||||||
|
-version = "6.0"
|
||||||
|
+version = "7.0"
|
||||||
|
|
||||||
|
[dependencies.sequoia-openpgp]
|
||||||
|
version = "1.0"
|
||||||
|
@@ -67,7 +71,7 @@
|
||||||
|
version = "1"
|
||||||
|
|
||||||
|
[dev-dependencies.assert_cmd]
|
||||||
|
-version = "1.0.1"
|
||||||
|
+version = "2.0.0"
|
||||||
|
|
||||||
|
[dev-dependencies.predicates]
|
||||||
|
version = "1.0.5"
|
||||||
|
@@ -89,7 +93,6 @@
|
||||||
|
version = "0.2"
|
||||||
|
|
||||||
|
[features]
|
||||||
|
-crypto-cng = ["sequoia-openpgp/crypto-cng"]
|
||||||
|
crypto-nettle = ["sequoia-openpgp/crypto-nettle"]
|
||||||
|
default = ["crypto-nettle"]
|
||||||
|
|
@ -0,0 +1,147 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.3.5)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 2;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 24
|
||||||
|
%bcond_without check
|
||||||
|
|
||||||
|
%global crate sequoia-keyring-linter
|
||||||
|
|
||||||
|
Name: rust-sequoia-keyring-linter
|
||||||
|
Version: 1.0.1
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Linter for keyrings
|
||||||
|
|
||||||
|
License: GPL-2.0-or-later
|
||||||
|
URL: https://crates.io/crates/sequoia-keyring-linter
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * exclude files that are only useful for upstream development
|
||||||
|
# * bump rpassword dependency from 6 to 7
|
||||||
|
# * bump assert_cmd dev-dependency from 1.0.1 to 2.0.0
|
||||||
|
# * remove feature for Windows-specific cryptography
|
||||||
|
Patch: sequoia-keyring-linter-fix-metadata.diff
|
||||||
|
# https://gitlab.com/sequoia-pgp/keyring-linter/-/merge_requests/9
|
||||||
|
Patch: 0001-build-fix-file-names-for-generated-manpage-and-shell.patch
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging >= 23
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
A linter for keyrings.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package -n %{crate}
|
||||||
|
Summary: %{summary}
|
||||||
|
# (MIT OR Apache-2.0) AND Unicode-DFS-2016
|
||||||
|
# Apache-2.0
|
||||||
|
# Apache-2.0 AND MIT
|
||||||
|
# Apache-2.0 OR MIT
|
||||||
|
# Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT
|
||||||
|
# BSL-1.0
|
||||||
|
# GPL-2.0-or-later
|
||||||
|
# LGPL-2.0-or-later
|
||||||
|
# LGPL-3.0 OR GPL-2.0 OR GPL-3.0
|
||||||
|
# MIT
|
||||||
|
# MIT OR Apache-2.0
|
||||||
|
# MIT OR Apache-2.0 OR Zlib
|
||||||
|
# Unlicense OR MIT
|
||||||
|
# Zlib OR Apache-2.0 OR MIT
|
||||||
|
License: GPL-2.0-or-later AND Apache-2.0 AND BSL-1.0 AND LGPL-2.0-or-later AND MIT AND Unicode-DFS-2016 AND (Apache-2.0 OR MIT) AND (Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT) AND (LGPL-3.0 OR GPL-2.0 OR GPL-3.0) AND (MIT OR Apache-2.0 OR Zlib) AND (Unlicense OR MIT)
|
||||||
|
# LICENSE.dependencies contains a full license breakdown
|
||||||
|
|
||||||
|
%description -n %{crate} %{_description}
|
||||||
|
|
||||||
|
%files -n %{crate}
|
||||||
|
%license LICENSE.txt
|
||||||
|
%license LICENSE.dependencies
|
||||||
|
%doc README.md
|
||||||
|
%{_bindir}/sq-keyring-linter
|
||||||
|
%{_mandir}/man1/sq-keyring-linter*
|
||||||
|
%{bash_completions_dir}/sq-keyring-linter.bash
|
||||||
|
%{fish_completions_dir}/sq-keyring-linter.fish
|
||||||
|
%{zsh_completions_dir}/_sq-keyring-linter
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
%cargo_license_summary
|
||||||
|
%{cargo_license} > LICENSE.dependencies
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
# install manual pages
|
||||||
|
install -Dpm 0644 target/release/build/%{crate}-*/out/sq-keyring-linter.1 \
|
||||||
|
%{buildroot}/%{_mandir}/man1/sq-keyring-linter.1
|
||||||
|
# install shell completions
|
||||||
|
install -Dpm 0644 target/release/build/%{crate}-*/out/sq-keyring-linter.bash \
|
||||||
|
%{buildroot}/%{bash_completions_dir}/sq-keyring-linter.bash
|
||||||
|
install -Dpm 0644 target/release/build/%{crate}-*/out/sq-keyring-linter.fish \
|
||||||
|
%{buildroot}/%{fish_completions_dir}/sq-keyring-linter.fish
|
||||||
|
install -Dpm 0644 target/release/build/%{crate}-*/out/_sq-keyring-linter \
|
||||||
|
%{buildroot}/%{zsh_completions_dir}/_sq-keyring-linter
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 1.0.1-2
|
||||||
|
- Rebuilt for MSVSphere 9.3
|
||||||
|
|
||||||
|
* Thu May 18 2023 Fabio Valentini <decathorpe@gmail.com> - 1.0.1-2
|
||||||
|
- Rebuild for sequoia-openpgp v1.16
|
||||||
|
|
||||||
|
* Sat May 06 2023 Fabio Valentini <decathorpe@gmail.com> - 1.0.1-1
|
||||||
|
- Update to version 1.0.1; Fixes RHBZ#2168872
|
||||||
|
|
||||||
|
* Fri Mar 24 2023 Davide Cavalca <dcavalca@fedoraproject.org> - 1.0.0-4
|
||||||
|
- Fix EPEL 9 build
|
||||||
|
|
||||||
|
* Sun Feb 05 2023 Fabio Valentini <decathorpe@gmail.com> - 1.0.0-3
|
||||||
|
- Rebuild for fixed frame pointer compiler flags in Rust RPM macros
|
||||||
|
|
||||||
|
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jan 11 2023 Fabio Valentini <decathorpe@gmail.com> - 1.0.0-1
|
||||||
|
- Update to version 1.0.0; Fixes RHBZ#2138837
|
||||||
|
|
||||||
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.0-9
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Mar 16 2022 Fabio Valentini <decathorpe@gmail.com> - 0.5.0-8
|
||||||
|
- Rebuild with sequoia-openpgp 1.8.0
|
||||||
|
|
||||||
|
* Tue Feb 15 2022 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 0.5.0-7
|
||||||
|
- Rebuild with package notes
|
||||||
|
|
||||||
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.0-6
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Nov 14 2021 Robert-André Mauchin <zebob.m@gmail.com> - 0.5.0-5
|
||||||
|
- Bump assert_cmd to 2.0.0
|
||||||
|
|
||||||
|
* Tue Jul 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.0-3
|
||||||
|
- Second attempt - Rebuilt for
|
||||||
|
https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Apr 13 2021 Fabio Valentini <decathorpe@gmail.com> - 0.5.0-2
|
||||||
|
- Temporarily ignore integer overflow in test suite on 32-bit architectures.
|
||||||
|
|
||||||
|
* Thu Apr 08 2021 Fabio Valentini <decathorpe@gmail.com> - 0.5.0-1
|
||||||
|
- Initial package
|
||||||
|
|
Loading…
Reference in new issue