Update to version 0.3.2

epel9
Fabio Valentini 2 years ago
parent e2c3eb6a72
commit 8059d21805
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -1 +1,2 @@
/sequoia-cert-store-0.2.0.crate /sequoia-cert-store-0.2.0.crate
/sequoia-cert-store-0.3.2.crate

@ -5,7 +5,7 @@
%global crate sequoia-cert-store %global crate sequoia-cert-store
Name: rust-sequoia-cert-store Name: rust-sequoia-cert-store
Version: 0.2.0 Version: 0.3.2
Release: %autorelease Release: %autorelease
Summary: Certificate database interface Summary: Certificate database interface
@ -15,8 +15,7 @@ Source: %{crates_source}
# Automatically generated patch to strip foreign dependencies # Automatically generated patch to strip foreign dependencies
Patch: sequoia-cert-store-fix-metadata-auto.diff Patch: sequoia-cert-store-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes # Manually created patch for downstream crate metadata changes
# * bump sequoia-net dependency from 0.26 to 0.27 # * temporarily downgrade rusqlite dependency from 0.29 to 0.28
# * expose features for crypto backends without setting a default
# * exclude integration tests, test data, and scripts from installed files # * exclude integration tests, test data, and scripts from installed files
Patch: sequoia-cert-store-fix-metadata.diff Patch: sequoia-cert-store-fix-metadata.diff
@ -54,51 +53,23 @@ use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+crypto-nettle-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+crypto-nettle-devel %{_description}
This package contains library source intended for building other packages which
use the "crypto-nettle" feature of the "%{crate}" crate.
%files -n %{name}+crypto-nettle-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+crypto-openssl-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+crypto-openssl-devel %{_description}
This package contains library source intended for building other packages which
use the "crypto-openssl" feature of the "%{crate}" crate.
%files -n %{name}+crypto-openssl-devel
%ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep %cargo_prep
%generate_buildrequires %generate_buildrequires
# ensure all dependencies for building tests are available %cargo_generate_buildrequires
%cargo_generate_buildrequires -f crypto-nettle,crypto-openssl
%build %build
# build with the default crypto backend (Nettle) # build with the default crypto backend (Nettle)
%cargo_build -f crypto-nettle %cargo_build -f sequoia-openpgp/crypto-nettle
%install %install
%cargo_install -f crypto-nettle %cargo_install
%if %{with check} %if %{with check}
%check %check
# run tests with the default crypto backend (Nettle) %cargo_test
%cargo_test -f crypto-nettle
# run tests with the OpenSSL crypto backend
%cargo_test -f crypto-openssl
%endif %endif
%changelog %changelog

@ -1,12 +1,15 @@
--- sequoia-cert-store-0.2.0/Cargo.toml 1970-01-01T00:00:01+00:00 --- sequoia-cert-store-0.3.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ sequoia-cert-store-0.2.0/Cargo.toml 2023-05-10T21:34:03.693854+00:00 +++ sequoia-cert-store-0.3.2/Cargo.toml 2023-08-02T11:51:23.515080+00:00
@@ -88,10 +88,5 @@ @@ -101,13 +101,5 @@
features = ["crypto-nettle"] ]
default-features = false default-features = false
-[target."cfg(windows)".dev-dependencies.sequoia-openpgp] -[target."cfg(windows)".dev-dependencies.sequoia-openpgp]
-version = "1" -version = "1"
-features = ["crypto-cng"] -features = [
- "crypto-cng",
- "__implicit-crypto-backend-for-tests",
-]
-default-features = false -default-features = false
- -
[badges.maintenance] [badges.maintenance]

@ -1,32 +1,19 @@
--- sequoia-cert-store-0.2.0/Cargo.toml 1970-01-01T00:00:01+00:00 --- sequoia-cert-store-0.3.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ sequoia-cert-store-0.2.0/Cargo.toml 2023-05-10T21:35:31.582209+00:00 +++ sequoia-cert-store-0.3.2/Cargo.toml 2023-08-02T11:52:12.863201+00:00
@@ -36,6 +36,7 @@ @@ -36,6 +36,7 @@
license = "LGPL-2.0-or-later" license = "LGPL-2.0-or-later"
repository = "https://gitlab.com/sequoia-pgp/sequoia-cert-store" repository = "https://gitlab.com/sequoia-pgp/sequoia-cert-store"
resolver = "2" resolver = "2"
+exclude = ["/tests/"] +exclude = ["/tests"]
[package.metadata.docs.rs] [package.metadata.docs.rs]
features = ["sequoia-openpgp/default"] features = ["sequoia-openpgp/default"]
@@ -66,7 +67,7 @@ @@ -66,7 +67,7 @@
version = "1" version = "1"
[dependencies.sequoia-net] [dependencies.rusqlite]
-version = "0.26" -version = "0.29"
+version = "0.27" +version = "0.28"
default-features = false features = [
"collation",
[dependencies.sequoia-openpgp] "blob",
@@ -85,8 +86,11 @@
[target."cfg(not(windows))".dev-dependencies.sequoia-openpgp]
version = "1"
-features = ["crypto-nettle"]
default-features = false
+
+[features]
+crypto-nettle = ["sequoia-openpgp/crypto-nettle"]
+crypto-openssl = ["sequoia-openpgp/crypto-openssl"]
[badges.maintenance]
status = "actively-developed"

@ -1 +1 @@
SHA512 (sequoia-cert-store-0.2.0.crate) = 805b4880ca03c36dce18b0d5c01398d372129bae8b06aaf0d0472795bef19c3d91fb468fa8316cd99d29575ec7c214d3a669bb9066c70d779baffe620f132386 SHA512 (sequoia-cert-store-0.3.2.crate) = da8b247aef940d93eb29a0b6c9ccc11759a87876eb7b9bb4a9629b95bcf6da086175e61393040a8a7cdc7ac5e42cfe535a4d3a8e85d07c3c9bc45e25bcf64211

Loading…
Cancel
Save