Drop CI feature and associated diesel dependency

epel9 imports/e9/rust-semver0.11-0.11.0-7.el9
Fabio Valentini 2 years ago
parent 33934e6358
commit 8c0c98a43e
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -13,6 +13,9 @@ Summary: Semantic version parsing and comparison
License: MIT OR Apache-2.0
URL: https://crates.io/crates/semver
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * remove CI feature and associated diesel dependency
Patch: semver-fix-metadata.diff
BuildRequires: rust-packaging >= 21
@ -48,30 +51,6 @@ use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ci-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+ci-devel %{_description}
This package contains library source intended for building other packages which
use the "ci" feature of the "%{crate}" crate.
%files -n %{name}+ci-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+diesel-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+diesel-devel %{_description}
This package contains library source intended for building other packages which
use the "diesel" feature of the "%{crate}" crate.
%files -n %{name}+diesel-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch

@ -0,0 +1,18 @@
--- semver-0.11.0/Cargo.toml 2020-09-24T13:48:56+00:00
+++ semver-0.11.0/Cargo.toml 2023-08-04T11:08:53.557908+00:00
@@ -22,9 +22,6 @@
categories = ["development-tools", "parser-implementations"]
license = "MIT/Apache-2.0"
repository = "https://github.com/steveklabnik/semver"
-[dependencies.diesel]
-version = "1.1"
-optional = true
[dependencies.semver-parser]
version = "0.10.0"
@@ -39,5 +36,4 @@
version = "1.0"
[features]
-ci = ["serde", "diesel/sqlite"]
default = []
Loading…
Cancel
Save