commit
ddd3bb6197
@ -0,0 +1 @@
|
||||
SOURCES/sdd-3.0.4.crate
|
@ -0,0 +1 @@
|
||||
d99bb9e947634563fd68b9ef355e68bb778ce5c9 SOURCES/sdd-3.0.4.crate
|
@ -0,0 +1,7 @@
|
||||
[package]
|
||||
summary = "Containers and utilities for concurrent and asynchronous programming"
|
||||
cargo-toml-patch-comments = [
|
||||
"drop unused, benchmark-only criterion dev-dependency",
|
||||
"drop unused, optional dependency for loom perturbation testing",
|
||||
]
|
||||
|
@ -0,0 +1,20 @@
|
||||
--- sdd-3.0.4/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ sdd-3.0.4/Cargo.toml 2024-10-20T19:38:17.340927+00:00
|
||||
@@ -42,17 +42,5 @@
|
||||
name = "sdd"
|
||||
path = "src/lib.rs"
|
||||
|
||||
-[[bench]]
|
||||
-name = "ebr"
|
||||
-path = "benches/ebr.rs"
|
||||
-harness = false
|
||||
-
|
||||
-[dependencies.loom]
|
||||
-version = "0.7"
|
||||
-optional = true
|
||||
-
|
||||
-[dev-dependencies.criterion]
|
||||
-version = "0.5"
|
||||
-
|
||||
[dev-dependencies.static_assertions]
|
||||
version = "1.1"
|
@ -0,0 +1,101 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.7.3)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 1;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 26
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate sdd
|
||||
|
||||
Name: rust-sdd
|
||||
Version: 3.0.4
|
||||
Release: %autorelease
|
||||
Summary: Containers and utilities for concurrent and asynchronous programming
|
||||
|
||||
License: Apache-2.0
|
||||
URL: https://crates.io/crates/sdd
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * drop unused, benchmark-only criterion dev-dependency
|
||||
# * drop unused, optional dependency for loom perturbation testing
|
||||
Patch: sdd-fix-metadata.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
Scalable lock-free delayed memory reclaimer.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 3.0.4-1
|
||||
- Rebuilt for MSVSphere 10
|
||||
|
||||
## START: Generated by rpmautospec
|
||||
* Sun Oct 20 2024 Fabio Valentini <decathorpe@gmail.com> - 3.0.4-1
|
||||
- Update to version 3.0.4; Fixes RHBZ#2318142
|
||||
|
||||
* Wed Sep 18 2024 Fabio Valentini <decathorpe@gmail.com> - 3.0.3-1
|
||||
- Update to version 3.0.3; Fixes RHBZ#2303975
|
||||
|
||||
* Fri Aug 02 2024 Fabio Valentini <decathorpe@gmail.com> - 2.1.0-1
|
||||
- Update to version 2.1.0; Fixes RHBZ#2297900
|
||||
|
||||
* Sat Jul 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||
|
||||
* Tue Jul 02 2024 Fabio Valentini <decathorpe@gmail.com> - 0.2.0-1
|
||||
- Initial import (#2291307)
|
||||
## END: Generated by rpmautospec
|
Loading…
Reference in new issue