parent
7509ef4fcb
commit
15ef9ee3a9
@ -0,0 +1 @@
|
||||
/sct-0.6.0.crate
|
@ -0,0 +1,80 @@
|
||||
# Generated by rust2rpm 17
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate sct
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.6.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Certificate transparency SCT verification library
|
||||
|
||||
# Upstream license specification: Apache-2.0/ISC/MIT
|
||||
License: ASL 2.0 or ISC or MIT
|
||||
URL: https://crates.io/crates/sct
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
# * Exclude useless files, https://github.com/ctz/sct.rs/pull/5
|
||||
Patch0: sct-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
# ring is not available on those architectures
|
||||
ExcludeArch: s390x %{power64}
|
||||
%if %{__cargo_skip_build}
|
||||
BuildArch: noarch
|
||||
%endif
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%global _description %{expand:
|
||||
Certificate transparency SCT verification library.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license LICENSE LICENSE-MIT LICENSE-ISC LICENSE-APACHE
|
||||
%doc README.md
|
||||
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use "default" feature of "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sun Jan 03 18:21:25 CET 2021 Igor Raits <igor.raits@gmail.com> - 0.6.0-1
|
||||
- Initial package
|
@ -0,0 +1,10 @@
|
||||
--- sct-0.6.0/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||
+++ sct-0.6.0/Cargo.toml 2021-01-03T17:23:55.347754+00:00
|
||||
@@ -21,6 +21,7 @@
|
||||
categories = ["network-programming", "cryptography"]
|
||||
license = "Apache-2.0/ISC/MIT"
|
||||
repository = "https://github.com/ctz/sct.rs"
|
||||
+exclude = ["/admin/"]
|
||||
[dependencies.ring]
|
||||
version = "0.16.0"
|
||||
|
Loading…
Reference in new issue