parent
a3450e62c7
commit
597f2237e5
@ -0,0 +1 @@
|
|||||||
|
/scroll_derive-0.8.0.crate
|
@ -0,0 +1,70 @@
|
|||||||
|
# Generated by rust2rpm
|
||||||
|
# scroll_derive(dev) -> scroll(opt) -> scroll_derive
|
||||||
|
%bcond_with check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate scroll_derive
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 0.8.0
|
||||||
|
Release: 2%{?dist}
|
||||||
|
Summary: Macros 1.1 derive implementation for Pread and Pwrite traits from scroll crate
|
||||||
|
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/scroll_derive
|
||||||
|
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||||
|
# Initial patched metadata
|
||||||
|
# * Bump scroll to 0.8, https://github.com/m4b/scroll_derive/pull/1
|
||||||
|
Patch0: scroll_derive-0.8.0-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
# [dependencies]
|
||||||
|
BuildRequires: (crate(quote) >= 0.3.15 with crate(quote) < 0.4.0)
|
||||||
|
BuildRequires: (crate(syn) >= 0.11.11 with crate(syn) < 0.12.0)
|
||||||
|
%if %{with check}
|
||||||
|
# [dev-dependencies]
|
||||||
|
BuildRequires: (crate(scroll) >= 0.8.0 with crate(scroll) < 0.9.0)
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%description
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
A macros 1.1 derive implementation for Pread and Pwrite traits from the scroll
|
||||||
|
crate.
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use %{crate} from crates.io.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE
|
||||||
|
%doc README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version}/
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Dec 04 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.8.0-2
|
||||||
|
- Bump scroll to 0.8
|
||||||
|
|
||||||
|
* Sun Dec 03 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.8.0-1
|
||||||
|
- Initial package
|
@ -0,0 +1,8 @@
|
|||||||
|
--- scroll_derive-0.8.0/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||||
|
+++ scroll_derive-0.8.0/Cargo.toml 2017-12-04T10:23:24.057401+01:00
|
||||||
|
@@ -29,4 +29,4 @@
|
||||||
|
[dependencies.syn]
|
||||||
|
version = "0.11.11"
|
||||||
|
[dev-dependencies.scroll]
|
||||||
|
-version = "0.7.0"
|
||||||
|
+version = "0.8"
|
Loading…
Reference in new issue