parent
f289387f62
commit
ac5c59043c
@ -0,0 +1 @@
|
||||
/scroll-0.7.0.crate
|
@ -0,0 +1,64 @@
|
||||
# Generated by rust2rpm
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate scroll
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.7.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Powerful, extensible, generic, endian-aware Read/Write traits for byte buffers
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/scroll
|
||||
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||
# Initial patched metadata
|
||||
# * Bump rayon to 0.9, https://github.com/m4b/scroll/commit/2b8ec1ccbf64fc0fa09cced9e9590186bc0c059e
|
||||
Patch0: scroll-0.7.0-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
%if %{with check}
|
||||
# [dev-dependencies]
|
||||
BuildRequires: (crate(byteorder) >= 1.0.0 with crate(byteorder) < 2.0.0)
|
||||
BuildRequires: (crate(rayon) >= 0.9.0 with crate(rayon) < 0.10.0)
|
||||
%endif
|
||||
|
||||
%description
|
||||
%{summary}.
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel
|
||||
A suite of powerful, extensible, generic, endian-aware Read/Write traits for
|
||||
byte buffers.
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use %{crate} from crates.io.
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%files devel
|
||||
%license LICENSE
|
||||
%doc README.md
|
||||
%{cargo_registry}/%{crate}-%{version}/
|
||||
|
||||
%changelog
|
||||
* Fri Dec 01 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.0-1
|
||||
- Initial package
|
@ -0,0 +1,11 @@
|
||||
--- scroll-0.7.0/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||
+++ scroll-0.7.0/Cargo.toml 2017-12-01T15:47:19.695643+01:00
|
||||
@@ -24,7 +24,7 @@
|
||||
version = "1.0.0"
|
||||
|
||||
[dev-dependencies.rayon]
|
||||
-version = "0.8.0"
|
||||
+version = "0.9.0"
|
||||
|
||||
[features]
|
||||
std = []
|
Loading…
Reference in new issue