Update to version 2.1.17; Fixes RHBZ#2310702

epel10
Fabio Valentini 5 months ago
parent e22bdf606a
commit 631b36b087
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -1 +1,2 @@
/scc-2.1.6.crate
/scc-2.1.17.crate

@ -1,13 +1,11 @@
# Generated by rust2rpm 26
# * non-deterministic test failures:
# https://github.com/wvwwvwwv/scalable-concurrent-containers/issues/153
%bcond_with check
%bcond_without check
%global debug_package %{nil}
%global crate scc
Name: rust-scc
Version: 2.1.6
Version: 2.1.17
Release: %autorelease
Summary: Containers and utilities for concurrent and asynchronous programming
@ -16,6 +14,7 @@ URL: https://crates.io/crates/scc
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop unused, benchmark-only criterion dev-dependency
# * drop features for perturbation testing with loom
Patch: scc-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24

@ -2,11 +2,6 @@
summary = "Containers and utilities for concurrent and asynchronous programming"
cargo-toml-patch-comments = [
"drop unused, benchmark-only criterion dev-dependency",
]
[tests]
run = ["none"]
comments = [
"non-deterministic test failures: https://github.com/wvwwvwwv/scalable-concurrent-containers/issues/153",
"drop features for perturbation testing with loom",
]

@ -1,31 +1,40 @@
--- scc-2.1.6/Cargo.toml 1970-01-01T00:00:01+00:00
+++ scc-2.1.6/Cargo.toml 2024-08-02T18:38:22.563456+00:00
@@ -34,35 +34,12 @@
license = "Apache-2.0"
repository = "https://github.com/wvwwvwwv/scalable-concurrent-containers/"
--- scc-2.1.17/Cargo.toml 1970-01-01T00:00:01+00:00
+++ scc-2.1.17/Cargo.toml 2024-09-18T15:04:47.778041+00:00
@@ -43,44 +43,12 @@
name = "scc"
path = "src/lib.rs"
-[[bench]]
-name = "bag"
-path = "benches/bag.rs"
-harness = false
-
-[[bench]]
-name = "hash_map"
-name = "hash_cache"
-path = "benches/hash_cache.rs"
-harness = false
-
-[[bench]]
-name = "hash_index"
-path = "benches/hash_index.rs"
-harness = false
-
-[[bench]]
-name = "hash_cache"
-name = "hash_map"
-path = "benches/hash_map.rs"
-harness = false
-
-[[bench]]
-name = "tree_index"
-path = "benches/tree_index.rs"
-harness = false
-
-[dependencies.loom]
-version = "0.7"
-optional = true
-
[dependencies.sdd]
version = "2.1.0"
version = "3.0"
[dependencies.serde]
version = "1.0"
@ -36,3 +45,13 @@
[dev-dependencies.futures]
version = "0.3"
@@ -100,9 +68,3 @@
[dev-dependencies.tokio]
version = "1.40"
features = ["full"]
-
-[features]
-loom = [
- "dep:loom",
- "sdd/loom",
-]

@ -1 +1 @@
SHA512 (scc-2.1.6.crate) = fc26b41ad03f91d7cdfaf77babaf096417b205b715df8928b5141240db60b65155cdd6c207bf5763157b2a2cd3c70c677c37dcd0c6cba274a310e16b5040cf33
SHA512 (scc-2.1.17.crate) = 548a77ca67a7e49a3b7b29a0339da9bccd42d6be23be4b4b3134613bd23a37629ab12cd669a7fbac1d9403446476a778bcb608d7ed1e6d0126a7d241a9496fdf

Loading…
Cancel
Save