Initial import (#2291306)
parent
96ff75f249
commit
526e754f86
@ -0,0 +1 @@
|
|||||||
|
/scc-2.1.6.crate
|
@ -0,0 +1,85 @@
|
|||||||
|
# Generated by rust2rpm 26
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate scc
|
||||||
|
|
||||||
|
Name: rust-scc
|
||||||
|
Version: 2.1.6
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Containers and utilities for concurrent and asynchronous programming
|
||||||
|
|
||||||
|
License: Apache-2.0
|
||||||
|
URL: https://crates.io/crates/scc
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * drop unused, benchmark-only criterion dev-dependency
|
||||||
|
Patch: scc-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: cargo-rpm-macros >= 24
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
High performance containers and utilities for concurrent and
|
||||||
|
asynchronous programming.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE
|
||||||
|
%doc %{crate_instdir}/CHANGELOG.md
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+serde-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+serde-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "serde" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+serde-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
%autochangelog
|
@ -0,0 +1,6 @@
|
|||||||
|
[package]
|
||||||
|
summary = "Containers and utilities for concurrent and asynchronous programming"
|
||||||
|
cargo-toml-patch-comments = [
|
||||||
|
"drop unused, benchmark-only criterion dev-dependency",
|
||||||
|
]
|
||||||
|
|
@ -0,0 +1,38 @@
|
|||||||
|
--- scc-2.1.6/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ scc-2.1.6/Cargo.toml 2024-08-02T18:38:22.563456+00:00
|
||||||
|
@@ -34,35 +34,12 @@
|
||||||
|
license = "Apache-2.0"
|
||||||
|
repository = "https://github.com/wvwwvwwv/scalable-concurrent-containers/"
|
||||||
|
|
||||||
|
-[[bench]]
|
||||||
|
-name = "bag"
|
||||||
|
-harness = false
|
||||||
|
-
|
||||||
|
-[[bench]]
|
||||||
|
-name = "hash_map"
|
||||||
|
-harness = false
|
||||||
|
-
|
||||||
|
-[[bench]]
|
||||||
|
-name = "hash_index"
|
||||||
|
-harness = false
|
||||||
|
-
|
||||||
|
-[[bench]]
|
||||||
|
-name = "hash_cache"
|
||||||
|
-harness = false
|
||||||
|
-
|
||||||
|
-[[bench]]
|
||||||
|
-name = "tree_index"
|
||||||
|
-harness = false
|
||||||
|
-
|
||||||
|
[dependencies.sdd]
|
||||||
|
version = "2.1.0"
|
||||||
|
|
||||||
|
[dependencies.serde]
|
||||||
|
version = "1.0"
|
||||||
|
optional = true
|
||||||
|
-
|
||||||
|
-[dev-dependencies.criterion]
|
||||||
|
-version = "0.5"
|
||||||
|
|
||||||
|
[dev-dependencies.futures]
|
||||||
|
version = "0.3"
|
Loading…
Reference in new issue