Initial import (#1689564)
parent
8104deb4de
commit
ecef89c5b9
@ -0,0 +1,72 @@
|
|||||||
|
# Generated by rust2rpm
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate scan_fmt
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 0.1.3
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Simple scanf()-like input for Rust
|
||||||
|
|
||||||
|
License: MIT
|
||||||
|
URL: https://crates.io/crates/scan_fmt
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Initial patched metadata
|
||||||
|
# - Bump regex to 1.0.0 https://github.com/wlentz/scan_fmt/pull/6
|
||||||
|
Patch0: scan_fmt-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
BuildRequires: (crate(regex/default) >= 1.0.0 with crate(regex/default) < 2.0.0)
|
||||||
|
|
||||||
|
%global _description \
|
||||||
|
A simple scanf()-like input for Rust.
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%doc README.md
|
||||||
|
%license LICENSE
|
||||||
|
%{cargo_registry}/%{crate}-%{version}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use "default" feature of "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sat Mar 09 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0.1.3-1
|
||||||
|
- Initial package
|
Binary file not shown.
@ -0,0 +1,8 @@
|
|||||||
|
--- scan_fmt-0.1.3/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||||
|
+++ scan_fmt-0.1.3/Cargo.toml 2019-03-16T18:36:46.105290+01:00
|
||||||
|
@@ -23,4 +23,4 @@
|
||||||
|
name = "scan_fmt"
|
||||||
|
path = "src/lib.rs"
|
||||||
|
[dependencies.regex]
|
||||||
|
-version = "0.2.6"
|
||||||
|
+version = "1.0.0"
|
Loading…
Reference in new issue