parent
6b3049bb93
commit
fd2f932b9c
@ -0,0 +1 @@
|
||||
/same-file-1.0.0.crate
|
@ -0,0 +1,75 @@
|
||||
# Generated by rust2rpm
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate same-file
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 1.0.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Simple crate for determining whether two file paths point to the same file
|
||||
|
||||
License: MIT or Unlicense
|
||||
URL: https://crates.io/crates/same-file
|
||||
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||
# Initial patched metadata
|
||||
# * No windows
|
||||
Patch0: same-file-1.0.0-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
%if %{with check}
|
||||
# [dev-dependencies]
|
||||
BuildRequires: (crate(rand) >= 0.3.0 with crate(rand) < 0.4.0)
|
||||
%endif
|
||||
|
||||
%description
|
||||
%{summary}.
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel
|
||||
A simple crate for determining whether two file paths point to the same file.
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use %{crate} from crates.io.
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%files devel
|
||||
%license COPYING
|
||||
%doc README.md
|
||||
%{cargo_registry}/%{crate}-%{version}/
|
||||
%exclude %{cargo_registry}/%{crate}-%{version}/appveyor.yml
|
||||
|
||||
%changelog
|
||||
* Sat Nov 04 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.0.0-1
|
||||
- Update to 1.0.0
|
||||
|
||||
* Wed Jun 14 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.3-4
|
||||
- Port to use rust-packaging
|
||||
|
||||
* Fri Feb 24 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.3-3
|
||||
- Use rich dependencies
|
||||
|
||||
* Sat Feb 18 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.3-2
|
||||
- Fix summary
|
||||
|
||||
* Sat Feb 18 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.3-1
|
||||
- Initial package
|
@ -0,0 +1,11 @@
|
||||
--- same-file-1.0.0/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||
+++ same-file-1.0.0/Cargo.toml 2017-11-04T13:12:35.260738+01:00
|
||||
@@ -23,8 +23,3 @@
|
||||
repository = "https://github.com/BurntSushi/same-file"
|
||||
[dev-dependencies.rand]
|
||||
version = "0.3"
|
||||
-[target."cfg(windows)".dependencies.winapi]
|
||||
-version = "0.2"
|
||||
-
|
||||
-[target."cfg(windows)".dependencies.kernel32-sys]
|
||||
-version = "0.2"
|
Loading…
Reference in new issue