Initial import (salsa20 0.9 compat package)

epel9 imports/e9/rust-salsa20_0.9-0.9.0-1.el9
Fabio Valentini 2 years ago
parent dc488a896d
commit e76f628886
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -0,0 +1 @@
/salsa20-0.9.0.crate

@ -1,3 +0,0 @@
# rust-salsa20_0.9
The rust-salsa20_0.9 package

@ -0,0 +1,111 @@
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate salsa20
Name: rust-salsa20_0.9
Version: 0.9.0
Release: %autorelease
Summary: Salsa20 Stream Cipher
License: MIT OR Apache-2.0
URL: https://crates.io/crates/salsa20
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * relax zeroize dependency (MSRV is irrelevant for Fedora)
Patch: salsa20-fix-metadata.diff
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Salsa20 Stream Cipher.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+expose-core-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+expose-core-devel %{_description}
This package contains library source intended for building other packages which
use the "expose-core" feature of the "%{crate}" crate.
%files -n %{name}+expose-core-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+hsalsa20-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+hsalsa20-devel %{_description}
This package contains library source intended for building other packages which
use the "hsalsa20" feature of the "%{crate}" crate.
%files -n %{name}+hsalsa20-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+zeroize-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+zeroize-devel %{_description}
This package contains library source intended for building other packages which
use the "zeroize" feature of the "%{crate}" crate.
%files -n %{name}+zeroize-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
# remove executable bit from non-executable source files
find -name "*.rs" -executable -print -exec chmod -x {} +
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog

@ -0,0 +1,11 @@
--- salsa20-0.9.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ salsa20-0.9.0/Cargo.toml 2023-05-30T15:07:50.572056+00:00
@@ -28,7 +28,7 @@
version = "0.3"
[dependencies.zeroize]
-version = ">=1, <1.4"
+version = "1"
optional = true
default-features = false
[dev-dependencies.cipher]

@ -0,0 +1 @@
SHA512 (salsa20-0.9.0.crate) = b4abd8ddc0a1fda00971bfbaa67e08d28aab1bde5cf5c5f831e64ba0c6dfa4d541591a85aee55cbcf5dd1c8f8aac80b258e64a98178e9c1c7f02b8d9998e16fc
Loading…
Cancel
Save