Initial import (#2034224)
parent
a1b6025f99
commit
cac565e472
@ -0,0 +1,4 @@
|
||||
/results_*/
|
||||
/*.src.rpm
|
||||
|
||||
/salsa20-0.8.1.crate
|
@ -0,0 +1,124 @@
|
||||
# Generated by rust2rpm 20
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate salsa20
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.8.1
|
||||
Release: %autorelease
|
||||
Summary: Salsa20 Stream Cipher
|
||||
|
||||
# Upstream license specification: MIT OR Apache-2.0
|
||||
License: MIT or ASL 2.0
|
||||
URL: https://crates.io/crates/salsa20
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
# * relax zeroize dependency (MSRV is irrelevant for Fedora)
|
||||
Patch0: salsa20-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%global _description %{expand:
|
||||
Salsa20 Stream Cipher.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license LICENSE-APACHE LICENSE-MIT
|
||||
%doc CHANGELOG.md README.md
|
||||
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+expose-core-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+expose-core-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "expose-core" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+expose-core-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+hsalsa20-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+hsalsa20-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "hsalsa20" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+hsalsa20-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+xsalsa20-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+xsalsa20-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "xsalsa20" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+xsalsa20-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+zeroize-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+zeroize-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "zeroize" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+zeroize-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
# remove executable bit from non-executable source files
|
||||
find -name "*.rs" -executable -print -exec chmod -x {} +
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
@ -0,0 +1,11 @@
|
||||
--- salsa20-0.8.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ salsa20-0.8.1/Cargo.toml 2021-12-20T12:29:18.816554+00:00
|
||||
@@ -28,7 +28,7 @@
|
||||
version = "0.3"
|
||||
|
||||
[dependencies.zeroize]
|
||||
-version = "=1.3"
|
||||
+version = "1.3"
|
||||
optional = true
|
||||
default-features = false
|
||||
[dev-dependencies.cipher]
|
Loading…
Reference in new issue