Update to version 0.7.0; Fixes RHBZ#2264747

Signed-off-by: Michel Lind <salimma@fedoraproject.org>
epel10
Michel Lind 7 months ago committed by Fabio Valentini
parent 914a8f46c4
commit 0ffb9ecd4c
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -1 +1,2 @@
/ruzstd-0.5.0.crate /ruzstd-0.5.0.crate
/ruzstd-0.7.0.crate

@ -1,12 +1,14 @@
# Generated by rust2rpm 25 # Generated by rust2rpm 26
# * data files required by tests are not included in published crates %bcond_without check
%bcond_with check
%global debug_package %{nil} %global debug_package %{nil}
# prevent executables from being installed
%global cargo_install_bin 0
%global crate ruzstd %global crate ruzstd
Name: rust-ruzstd Name: rust-ruzstd
Version: 0.5.0 Version: 0.7.0
Release: %autorelease Release: %autorelease
Summary: Decoder for the zstd compression format Summary: Decoder for the zstd compression format
@ -14,11 +16,10 @@ License: MIT
URL: https://crates.io/crates/ruzstd URL: https://crates.io/crates/ruzstd
Source: %{crates_source} Source: %{crates_source}
# Manually created patch for downstream crate metadata changes # Manually created patch for downstream crate metadata changes
# * drop unused command-line applications
# * drop unused, benchmark-only criterion dev-dependency # * drop unused, benchmark-only criterion dev-dependency
Patch: ruzstd-fix-metadata.diff Patch: ruzstd-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24 BuildRequires: cargo-rpm-macros >= 26
%global _description %{expand: %global _description %{expand:
A decoder for the zstd compression format.} A decoder for the zstd compression format.}
@ -36,6 +37,7 @@ use the "%{crate}" crate.
%files devel %files devel
%license %{crate_instdir}/LICENSE %license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/Changelog.md
%doc %{crate_instdir}/Readme.md %doc %{crate_instdir}/Readme.md
%doc %{crate_instdir}/optimizations.md %doc %{crate_instdir}/optimizations.md
%{crate_instdir}/ %{crate_instdir}/
@ -52,6 +54,18 @@ use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+hash-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+hash-devel %{_description}
This package contains library source intended for building other packages which
use the "hash" feature of the "%{crate}" crate.
%files -n %{name}+hash-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel %package -n %{name}+std-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -79,7 +93,8 @@ use the "std" feature of the "%{crate}" crate.
%if %{with check} %if %{with check}
%check %check
%cargo_test # * test fixtures not shipped
%cargo_test -- -- --exact --skip tests::decode_corpus::test_decode_corpus_files --skip tests::dict_test::test_dict_decoding --skip tests::fuzz_regressions::test_all_artifacts --skip tests::test_block_header_reading --skip tests::test_decode_from_to --skip tests::test_frame_decoder --skip tests::test_frame_header_reading --skip tests::test_specific_file --skip tests::test_streaming
%endif %endif
%changelog %changelog

@ -0,0 +1,19 @@
[package]
cargo-install-bin = false
[tests]
skip = [
"tests::decode_corpus::test_decode_corpus_files",
"tests::dict_test::test_dict_decoding",
"tests::fuzz_regressions::test_all_artifacts",
"tests::test_block_header_reading",
"tests::test_decode_from_to",
"tests::test_frame_decoder",
"tests::test_frame_header_reading",
"tests::test_specific_file",
"tests::test_streaming",
]
skip-exact = true
comments = [
"test fixtures not shipped",
]

@ -1,32 +1,23 @@
--- ruzstd-0.5.0/Cargo.toml 1970-01-01T00:00:01+00:00 --- ruzstd-0.7.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ ruzstd-0.5.0/Cargo.toml 2023-11-29T18:54:43.112157+00:00 +++ ruzstd-0.7.0/Cargo.toml 2024-07-23T18:53:00.176423+00:00
@@ -24,18 +24,7 @@ @@ -39,10 +39,6 @@
readme = "Readme.md" name = "zstd_stream"
license = "MIT" required-features = ["std"]
repository = "https://github.com/KillingSpark/zstd-rs"
-
-[[bin]]
-name = "zstd"
-required-features = ["std"]
-
-[[bin]]
-name = "zstd_stream"
-required-features = ["std"]
-
-[[bench]] -[[bench]]
-name = "reversedbitreader_bench" -name = "reversedbitreader_bench"
-harness = false -harness = false
+autobins = false -
[dependencies.byteorder] [dependencies.byteorder]
version = "1.5" version = "1.5"
@@ -53,9 +42,6 @@ default-features = false
@@ -51,9 +47,6 @@
version = "1.6" version = "1.6"
optional = true
default-features = false default-features = false
-[dev-dependencies.criterion]
-version = "0.3"
- -
-[dev-dependencies.criterion]
-version = "0.5"
[dev-dependencies.rand] [dev-dependencies.rand]
version = "0.8.5" version = "0.8.5"
features = ["small_rng"]

@ -1 +1 @@
SHA512 (ruzstd-0.5.0.crate) = 27ce1c29be24181a3af5e55119d8350dd6d00389dff7096b17bfa683d7e79c8fe2eb8a2c9d5667edfb02ef7e4fad05186d56490362679d3d6d2a10faaee6f898 SHA512 (ruzstd-0.7.0.crate) = 06e1a584fb9abf214b9924391f305ce99c7d0278e6aadb99fe62f48746a7974daab74e8c324c9fa6170e3a4ad6ed4e967a458b6ec77c3dc044082edca2ea4fef

Loading…
Cancel
Save