commit
772657f782
@ -0,0 +1 @@
|
|||||||
|
SOURCES/rustls-pemfile-2.2.0.crate
|
@ -0,0 +1 @@
|
|||||||
|
5d055881ce910a13ea86e3977bce19dd45a89fa3 SOURCES/rustls-pemfile-2.2.0.crate
|
@ -0,0 +1,5 @@
|
|||||||
|
[package]
|
||||||
|
cargo-toml-patch-comments = [
|
||||||
|
"drop unused, benchmark-only bencher dev-dependency",
|
||||||
|
]
|
||||||
|
|
@ -0,0 +1,21 @@
|
|||||||
|
--- rustls-pemfile-2.2.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ rustls-pemfile-2.2.0/Cargo.toml 2024-10-19T09:46:11.174359+00:00
|
||||||
|
@@ -37,18 +37,10 @@
|
||||||
|
path = "tests/integration.rs"
|
||||||
|
required-features = ["std"]
|
||||||
|
|
||||||
|
-[[bench]]
|
||||||
|
-name = "benchmark"
|
||||||
|
-path = "benches/benchmark.rs"
|
||||||
|
-harness = false
|
||||||
|
-
|
||||||
|
[dependencies.pki-types]
|
||||||
|
version = "1.9"
|
||||||
|
package = "rustls-pki-types"
|
||||||
|
|
||||||
|
-[dev-dependencies.bencher]
|
||||||
|
-version = "0.1.5"
|
||||||
|
-
|
||||||
|
[features]
|
||||||
|
default = ["std"]
|
||||||
|
std = ["pki-types/std"]
|
@ -0,0 +1,138 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.7.3)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 1;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 26
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate rustls-pemfile
|
||||||
|
|
||||||
|
Name: rust-rustls-pemfile
|
||||||
|
Version: 2.2.0
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: Basic .pem file parser for keys and certificates
|
||||||
|
|
||||||
|
License: Apache-2.0 OR ISC OR MIT
|
||||||
|
URL: https://crates.io/crates/rustls-pemfile
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * drop unused, benchmark-only bencher dev-dependency
|
||||||
|
Patch: rustls-pemfile-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: cargo-rpm-macros >= 24
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
Basic .pem file parser for keys and certificates.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE
|
||||||
|
%license %{crate_instdir}/LICENSE-APACHE
|
||||||
|
%license %{crate_instdir}/LICENSE-ISC
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+std-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+std-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "std" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+std-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 2.2.0-1
|
||||||
|
- Rebuilt for MSVSphere 10
|
||||||
|
|
||||||
|
## START: Generated by rpmautospec
|
||||||
|
* Sat Oct 19 2024 Fabio Valentini <decathorpe@gmail.com> - 2.2.0-1
|
||||||
|
- Update to version 2.2.0; Fixes RHBZ#2315737
|
||||||
|
|
||||||
|
* Mon Aug 05 2024 Fabio Valentini <decathorpe@gmail.com> - 2.1.3-1
|
||||||
|
- Update to version 2.1.3; Fixes RHBZ#2302632
|
||||||
|
|
||||||
|
* Sat Jul 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.2-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Apr 19 2024 Fabio Valentini <decathorpe@gmail.com> - 2.1.2-1
|
||||||
|
- Update to version 2.1.2; Fixes RHBZ#2252308
|
||||||
|
|
||||||
|
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.4-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Nov 09 2023 Fabio Valentini <decathorpe@gmail.com> - 1.0.4-1
|
||||||
|
- Update to version 1.0.4; Fixes RHBZ#2248942
|
||||||
|
|
||||||
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.3-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jul 05 2023 Fabio Valentini <decathorpe@gmail.com> - 1.0.3-1
|
||||||
|
- Update to version 1.0.3; Fixes RHBZ#2218294
|
||||||
|
|
||||||
|
* Mon Jun 12 2023 Fabio Valentini <decathorpe@gmail.com> - 1.0.2-1
|
||||||
|
- Update to version 1.0.2; Fixes RHBZ#2159723
|
||||||
|
|
||||||
|
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Aug 11 2022 Fabio Valentini <decathorpe@gmail.com> - 1.0.1-1
|
||||||
|
- Update to version 1.0.1; Fixes RHBZ#2075477
|
||||||
|
|
||||||
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Mar 24 2022 Davide Cavalca <dcavalca@fedoraproject.org> - 0.3.0-1
|
||||||
|
- Initial import; Fixes: RHBZ#2024814
|
||||||
|
## END: Generated by rpmautospec
|
Loading…
Reference in new issue