Update to version 0.37.26

epel9 imports/e9/rust-rustix0.37-0.37.26-1.el9
Fabio Valentini 1 year ago
parent acb52bf382
commit 0c3bec1f64
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -1 +1,2 @@
/rustix-0.37.23.crate /rustix-0.37.23.crate
/rustix-0.37.26.crate

@ -1,18 +1,18 @@
# Generated by rust2rpm 24 # Generated by rust2rpm 25
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate rustix %global crate rustix
Name: rust-rustix0.37 Name: rust-rustix0.37
Version: 0.37.23 Version: 0.37.26
Release: %autorelease Release: %autorelease
Summary: Safe Rust bindings to POSIX/Unix/Linux/Winsock2-like syscalls Summary: Safe Rust bindings to POSIX/Unix/Linux/Winsock2-like syscalls
License: Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT License: Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT
URL: https://crates.io/crates/rustix URL: https://crates.io/crates/rustix
Source: %{crates_source} Source: %{crates_source}
# Automatically generated patch to strip foreign dependencies # Automatically generated patch to strip dependencies and normalize metadata
Patch: rustix-fix-metadata-auto.diff Patch: rustix-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes # Manually created patch for downstream crate metadata changes
# * drop dependencies on compiler internals # * drop dependencies on compiler internals
@ -21,7 +21,7 @@ Patch: rustix-fix-metadata.diff
# * unconditionally rebuild static objects from Assembly # * unconditionally rebuild static objects from Assembly
Patch: 0001-Unconditionally-compile-C-Assembly-code-from-source.patch Patch: 0001-Unconditionally-compile-C-Assembly-code-from-source.patch
BuildRequires: rust-packaging >= 21 BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand: %global _description %{expand:
Safe Rust bindings to POSIX/Unix/Linux/Winsock2-like syscalls.} Safe Rust bindings to POSIX/Unix/Linux/Winsock2-like syscalls.}
@ -398,7 +398,7 @@ use the "use-libc-auxv" feature of the "%{crate}" crate.
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version} -p1
%cargo_prep %cargo_prep
# Remove pre-built binaries # Remove pre-built binaries
rm -r src/backend/linux_raw/arch/outline/debug/ rm -r src/backend/linux_raw/arch/outline/debug/

@ -1,16 +1,6 @@
--- rustix-0.37.23/Cargo.toml 1970-01-01T00:00:01+00:00 --- rustix-0.37.26/Cargo.toml 1970-01-01T00:00:01+00:00
+++ rustix-0.37.23/Cargo.toml 2023-07-05T19:13:57.600367+00:00 +++ rustix-0.37.26/Cargo.toml 2023-10-19T14:21:38.952269+00:00
@@ -203,9 +203,6 @@ @@ -230,19 +230,3 @@
]
default-features = false
-[target."cfg(all(criterion, not(any(target_os = \"emscripten\", target_os = \"wasi\"))))".dev-dependencies.criterion]
-version = "0.4"
-
[target."cfg(all(not(rustix_use_libc), not(miri), target_os = \"linux\", any(target_arch = \"x86\", all(target_arch = \"x86_64\", target_pointer_width = \"64\"), all(target_endian = \"little\", any(target_arch = \"arm\", all(target_arch = \"aarch64\", target_pointer_width = \"64\"), target_arch = \"powerpc64\", target_arch = \"riscv64\", target_arch = \"mips\", target_arch = \"mips64\")))))".dependencies.libc]
version = "0.2.144"
features = ["extra_traits"]
@@ -240,19 +237,3 @@
version = "1.5.2" version = "1.5.2"
optional = true optional = true

@ -1,13 +1,9 @@
--- rustix-0.37.23/Cargo.toml 1970-01-01T00:00:01+00:00 --- rustix-0.37.26/Cargo.toml 1970-01-01T00:00:01+00:00
+++ rustix-0.37.23/Cargo.toml 2023-07-05T19:14:54.852609+00:00 +++ rustix-0.37.26/Cargo.toml 2023-10-19T14:22:38.958553+00:00
@@ -68,26 +68,8 @@ @@ -68,22 +68,8 @@
"wasm32-wasi", "wasm32-wasi",
] ]
-[[bench]]
-name = "mod"
-harness = false
-
-[dependencies.alloc] -[dependencies.alloc]
-version = "1.0.0" -version = "1.0.0"
-optional = true -optional = true
@ -27,7 +23,7 @@
[dependencies.io-lifetimes] [dependencies.io-lifetimes]
version = "1.0.10" version = "1.0.10"
@@ -127,7 +109,6 @@ @@ -120,7 +106,6 @@
[build-dependencies.cc] [build-dependencies.cc]
version = "1.0.68" version = "1.0.68"
@ -35,7 +31,7 @@
[features] [features]
all-apis = [ all-apis = [
@@ -149,6 +130,7 @@ @@ -142,6 +127,7 @@
"os_pipe", "os_pipe",
"fs-err", "fs-err",
] ]
@ -43,7 +39,7 @@
default = [ default = [
"std", "std",
"use-libc-auxv", "use-libc-auxv",
@@ -177,13 +159,6 @@ @@ -170,13 +156,6 @@
] ]
rand = [] rand = []
runtime = [] runtime = []

@ -1 +1 @@
SHA512 (rustix-0.37.23.crate) = 9dcc915b753b0ae9ea4d92d33f3a7c73e889ca0dc22abb95ec3d375e4188449d1bd6835c122598beb947fc8aaf884c59cc2cf55ab77f32480f5c17e789664988 SHA512 (rustix-0.37.26.crate) = ac9266a30274ce399d3856f0363ff55708ab5cbc817b6a1da31a2c14d14de3e00af4aff49adf1a9ddf3dbe2d6b6c8d667e6c9c5291e3cd3dc40020f73f3016b7

Loading…
Cancel
Save