commit
e26dc074c8
@ -0,0 +1 @@
|
|||||||
|
SOURCES/rustfft-6.2.0.crate
|
@ -0,0 +1 @@
|
|||||||
|
72cfe2b67b7bb931196a2707f9d756ce74d4ae15 SOURCES/rustfft-6.2.0.crate
|
@ -0,0 +1,24 @@
|
|||||||
|
--- rustfft-6.2.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||||
|
+++ rustfft-6.2.0/Cargo.toml 2024-01-30T12:39:04.735811+00:00
|
||||||
|
@@ -56,16 +56,12 @@
|
||||||
|
|
||||||
|
[dev-dependencies.getrandom]
|
||||||
|
version = "^0.2"
|
||||||
|
-features = ["js"]
|
||||||
|
|
||||||
|
[dev-dependencies.paste]
|
||||||
|
version = "1.0.9"
|
||||||
|
|
||||||
|
[dev-dependencies.rand]
|
||||||
|
version = "0.8"
|
||||||
|
-
|
||||||
|
-[dev-dependencies.wasm-bindgen-test]
|
||||||
|
-version = "^0.3.36"
|
||||||
|
|
||||||
|
[build-dependencies.version_check]
|
||||||
|
version = "0.9"
|
||||||
|
@@ -79,4 +75,3 @@
|
||||||
|
]
|
||||||
|
neon = []
|
||||||
|
sse = []
|
||||||
|
-wasm_simd = []
|
@ -0,0 +1,138 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.7.3)
|
||||||
|
## RPMAUTOSPEC: autorelease, autochangelog
|
||||||
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||||
|
release_number = 1;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
# Generated by rust2rpm 25
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate rustfft
|
||||||
|
|
||||||
|
Name: rust-rustfft
|
||||||
|
Version: 6.2.0
|
||||||
|
Release: %autorelease
|
||||||
|
Summary: High-performance FFT library written in pure Rust
|
||||||
|
|
||||||
|
License: MIT OR Apache-2.0
|
||||||
|
URL: https://crates.io/crates/rustfft
|
||||||
|
Source: %{crates_source}
|
||||||
|
# Manually created patch for downstream crate metadata changes
|
||||||
|
# * drop WASM-specific features and dependencies
|
||||||
|
Patch: rustfft-fix-metadata.diff
|
||||||
|
|
||||||
|
BuildRequires: cargo-rpm-macros >= 24
|
||||||
|
|
||||||
|
%global _description %{expand:
|
||||||
|
High-performance FFT library written in pure Rust.}
|
||||||
|
|
||||||
|
%description %{_description}
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license %{crate_instdir}/LICENSE-APACHE
|
||||||
|
%license %{crate_instdir}/LICENSE-MIT
|
||||||
|
%doc %{crate_instdir}/CHANGELOG.md
|
||||||
|
%doc %{crate_instdir}/README.md
|
||||||
|
%doc %{crate_instdir}/UpgradeGuide4to5.md
|
||||||
|
%{crate_instdir}/
|
||||||
|
|
||||||
|
%package -n %{name}+default-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+default-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "default" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+default-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+avx-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+avx-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "avx" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+avx-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+neon-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+neon-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "neon" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+neon-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%package -n %{name}+sse-devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description -n %{name}+sse-devel %{_description}
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages which
|
||||||
|
use the "sse" feature of the "%{crate}" crate.
|
||||||
|
|
||||||
|
%files -n %{name}+sse-devel
|
||||||
|
%ghost %{crate_instdir}/Cargo.toml
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%generate_buildrequires
|
||||||
|
%cargo_generate_buildrequires
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 6.2.0-1
|
||||||
|
- Rebuilt for MSVSphere 10
|
||||||
|
|
||||||
|
## START: Generated by rpmautospec
|
||||||
|
* Tue Jan 30 2024 Fabio Valentini <decathorpe@gmail.com> - 6.2.0-1
|
||||||
|
- Update to version 6.2.0; Fixes RHBZ#2259604
|
||||||
|
|
||||||
|
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 6.1.0-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 6.1.0-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 6.1.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Nov 11 2022 Orion Poplawski <orion@nwra.com> - 6.1.0-1
|
||||||
|
- Initial import
|
||||||
|
## END: Generated by rpmautospec
|
Loading…
Reference in new issue