parent
47beff886e
commit
66a976eaca
@ -0,0 +1 @@
|
|||||||
|
/rustc_version-0.2.1.crate
|
@ -0,0 +1,69 @@
|
|||||||
|
# Generated by rust2rpm
|
||||||
|
%bcond_without check
|
||||||
|
%global debug_package %{nil}
|
||||||
|
|
||||||
|
%global crate rustc_version
|
||||||
|
|
||||||
|
Name: rust-%{crate}
|
||||||
|
Version: 0.2.1
|
||||||
|
Release: 1%{?dist}
|
||||||
|
Summary: Library for querying the version of a installed rustc compiler
|
||||||
|
|
||||||
|
License: MIT or ASL 2.0
|
||||||
|
URL: https://crates.io/crates/rustc_version
|
||||||
|
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||||
|
# Initial patched metadata
|
||||||
|
# * bump semver to 0.9, https://github.com/Kimundi/rustc-version-rs/pull/19
|
||||||
|
Patch0: rustc_version-0.2.1-fix-metadata.diff
|
||||||
|
|
||||||
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
|
BuildRequires: rust-packaging
|
||||||
|
# [dependencies]
|
||||||
|
BuildRequires: (crate(semver) >= 0.9.0 with crate(semver) < 0.10.0)
|
||||||
|
|
||||||
|
%description
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: %{summary}
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
A library for querying the version of a installed rustc compiler.
|
||||||
|
|
||||||
|
This package contains library source intended for building other packages
|
||||||
|
which use %{crate} from crates.io.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{crate}-%{version} -p1
|
||||||
|
%cargo_prep
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cargo_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%cargo_install
|
||||||
|
|
||||||
|
%if %{with check}
|
||||||
|
%check
|
||||||
|
%cargo_test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%license LICENSE-MIT LICENSE-APACHE
|
||||||
|
%doc README.md
|
||||||
|
%{cargo_registry}/%{crate}-%{version}/
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Nov 10 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.1-1
|
||||||
|
- Bump semver to 0.9
|
||||||
|
|
||||||
|
* Thu Jun 15 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.1-1
|
||||||
|
- Update to 0.2.1
|
||||||
|
|
||||||
|
* Wed Jun 14 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.7-2
|
||||||
|
- Port to use rust-packaging
|
||||||
|
|
||||||
|
* Sun Feb 26 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.7-1
|
||||||
|
- Initial package
|
@ -0,0 +1,8 @@
|
|||||||
|
--- rustc_version-0.2.1/Cargo.toml 2017-03-27T14:26:06+02:00
|
||||||
|
+++ rustc_version-0.2.1/Cargo.toml 2017-11-10T16:14:57.589727+01:00
|
||||||
|
@@ -12,4 +12,4 @@
|
||||||
|
keywords = ["version", "rustc"]
|
||||||
|
|
||||||
|
[dependencies]
|
||||||
|
-semver = "0.6"
|
||||||
|
+semver = "0.9"
|
Loading…
Reference in new issue