Adapt to new packaging

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent d1fbef2e9b
commit b9b6a9aa8f
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

@ -6,38 +6,57 @@
Name: rust-%{crate} Name: rust-%{crate}
Version: 0.3.24 Version: 0.3.24
Release: 6%{?dist} Release: 7%{?dist}
Summary: Generic serialization/deserialization support Summary: Generic serialization/deserialization support
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0 License: MIT or ASL 2.0
URL: https://crates.io/crates/rustc-serialize URL: https://crates.io/crates/rustc-serialize
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata # Initial patched metadata
# * Bump rand to 0.4 # * Bump rand to 0.4
Patch0: rustc-serialize-0.3.24-fix-metadata.diff # * Exclude CI files
Patch0: rustc-serialize-fix-metadata.diff
ExclusiveArch: %{rust_arches} ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging BuildRequires: rust-packaging
%if %{with check} %if %{with check}
# [dev-dependencies] BuildRequires: (crate(rand/default) >= 0.4.0 with crate(rand/default) < 0.5.0)
BuildRequires: (crate(rand) >= 0.4.0 with crate(rand) < 0.5.0)
%endif %endif
%description %global _description \
%{summary}. Generic serialization/deserialization support corresponding to the\
`derive(RustcEncodable, RustcDecodable)` mode in the compiler. Also includes\
support for hex, base64, and json encoding and decoding.
%description %{_description}
%package devel %package devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
%description devel %description devel %{_description}
Generic serialization/deserialization support corresponding to the
`derive(RustcEncodable, RustcDecodable)` mode in the compiler. Also includes
support for hex, base64, and json encoding and decoding.
This package contains library source intended for building other packages This package contains library source intended for building other packages
which use %{crate} from crates.io. which use "%{crate}" crate.
%files devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.md
%{cargo_registry}/%{crate}-%{version}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version} -p1 %autosetup -n %{crate}-%{version} -p1
@ -54,13 +73,10 @@ which use %{crate} from crates.io.
%cargo_test %cargo_test
%endif %endif
%files devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.md
%{cargo_registry}/%{crate}-%{version}/
%exclude %{cargo_registry}/%{crate}-%{version}/appveyor.yml
%changelog %changelog
* Wed Oct 31 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.24-7
- Adapt to new packaging
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.24-6 * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.24-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

@ -1,8 +0,0 @@
--- rustc-serialize-0.3.24/Cargo.toml 2017-04-21T16:10:04+02:00
+++ rustc-serialize-0.3.24/Cargo.toml 2018-01-01T12:18:33.356847+01:00
@@ -15,4 +15,4 @@
"""
[dev-dependencies]
-rand = "0.3"
+rand = "0.4"

@ -0,0 +1,11 @@
--- rustc-serialize-0.3.24/Cargo.toml 2017-04-21T16:10:04+02:00
+++ rustc-serialize-0.3.24/Cargo.toml 2018-10-31T11:56:20.133187+01:00
@@ -13,6 +13,7 @@
`derive(RustcEncodable, RustcDecodable)` mode in the compiler. Also includes
support for hex, base64, and json encoding and decoding.
"""
+exclude = ["/.travis.yml", "/appveyor.yml"]
[dev-dependencies]
-rand = "0.3"
+rand = "0.4"
Loading…
Cancel
Save