Disable LTO to work around LLVM crashes on ppc64le

epel9
Fabio Valentini 2 years ago
parent 81d1891586
commit 2658d70424
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -1,25 +1,23 @@
# Generated by rust2rpm 18 # Generated by rust2rpm 23
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate rustc-demangle %global crate rustc-demangle
Name: rust-%{crate} Name: rust-rustc-demangle
Version: 0.1.21 Version: 0.1.21
Release: %autorelease Release: %autorelease
Summary: Rust compiler symbol demangling Summary: Rust compiler symbol demangling
# Upstream license specification: MIT/Apache-2.0 # Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0 License: MIT OR Apache-2.0
URL: https://crates.io/crates/rustc-demangle URL: https://crates.io/crates/rustc-demangle
Source: %{crates_source} Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * disable LTO to work around LLVM crashes on ppc64le
Patch: rustc-demangle-fix-metadata.diff
ExclusiveArch: %{rust_arches} BuildRequires: rust-packaging >= 21
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
%global _description %{expand: %global _description %{expand:
Rust compiler symbol demangling.} Rust compiler symbol demangling.}
@ -32,13 +30,14 @@ BuildArch: noarch
%description devel %{_description} %description devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "%{crate}" crate. use the "%{crate}" crate.
%files devel %files devel
%license LICENSE-MIT LICENSE-APACHE %license %{crate_instdir}/LICENSE-APACHE
%doc README.md %license %{crate_instdir}/LICENSE-MIT
%{cargo_registry}/%{crate}-%{version_no_tilde}/ %doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel %package -n %{name}+default-devel
Summary: %{summary} Summary: %{summary}
@ -46,11 +45,11 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description} %description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages This package contains library source intended for building other packages which
which use "default" feature of "%{crate}" crate. use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%prep %prep
%autosetup -n %{crate}-%{version_no_tilde} -p1 %autosetup -n %{crate}-%{version_no_tilde} -p1

@ -0,0 +1,11 @@
--- rustc-demangle-0.1.21/Cargo.toml 1970-01-01T00:00:01+00:00
+++ rustc-demangle-0.1.21/Cargo.toml 2022-12-15T13:04:12.788012+00:00
@@ -20,8 +20,6 @@
readme = "README.md"
license = "MIT/Apache-2.0"
repository = "https://github.com/alexcrichton/rustc-demangle"
-[profile.release]
-lto = true
[dependencies.compiler_builtins]
version = "0.1.2"
optional = true
Loading…
Cancel
Save