Update to version 1.28.1; Fixes RHBZ#2148310

epel9
Fabio Valentini 2 years ago
parent ef11c23a29
commit c318f55721
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -24,3 +24,4 @@
/rust_decimal-1.23.1.crate /rust_decimal-1.23.1.crate
/rust_decimal-1.25.0.crate /rust_decimal-1.25.0.crate
/rust_decimal-1.26.1.crate /rust_decimal-1.26.1.crate
/rust_decimal-1.28.1.crate

@ -1,3 +0,0 @@
# rust-rust_decimal
The rust-rust_decimal package

@ -1,11 +1,11 @@
# Generated by rust2rpm 22 # Generated by rust2rpm 24
%bcond_without check %bcond_without check
%global debug_package %{nil} %global debug_package %{nil}
%global crate rust_decimal %global crate rust_decimal
Name: rust-rust_decimal Name: rust-rust_decimal
Version: 1.26.1 Version: 1.28.1
Release: %autorelease Release: %autorelease
Summary: Decimal number implementation written in pure Rust Summary: Decimal number implementation written in pure Rust
@ -14,15 +14,14 @@ URL: https://crates.io/crates/rust_decimal
Source: %{crates_source} Source: %{crates_source}
# Manually created patch for downstream crate metadata changes # Manually created patch for downstream crate metadata changes
# * drop unused, benchmark-only criterion dev-dependency to speed up builds # * drop unused, benchmark-only criterion dev-dependency to speed up builds
# * drop unused features with missing dependencies
Patch: rust_decimal-fix-metadata.diff Patch: rust_decimal-fix-metadata.diff
ExclusiveArch: %{rust_arches} BuildRequires: cargo-rpm-macros >= 24
BuildRequires: rust-packaging >= 21
%global _description %{expand: %global _description %{expand:
Decimal number implementation written in pure Rust suitable for financial and Decimal number implementation written in pure Rust suitable for
fixed-precision calculations.} financial and fixed-precision calculations.}
%description %{_description} %description %{_description}
@ -56,6 +55,126 @@ use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel %files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bytecheck-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+bytecheck-devel %{_description}
This package contains library source intended for building other packages which
use the "bytecheck" feature of the "%{crate}" crate.
%files -n %{name}+bytecheck-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+byteorder-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+byteorder-devel %{_description}
This package contains library source intended for building other packages which
use the "byteorder" feature of the "%{crate}" crate.
%files -n %{name}+byteorder-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bytes-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+bytes-devel %{_description}
This package contains library source intended for building other packages which
use the "bytes" feature of the "%{crate}" crate.
%files -n %{name}+bytes-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+c-repr-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+c-repr-devel %{_description}
This package contains library source intended for building other packages which
use the "c-repr" feature of the "%{crate}" crate.
%files -n %{name}+c-repr-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+legacy-ops-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+legacy-ops-devel %{_description}
This package contains library source intended for building other packages which
use the "legacy-ops" feature of the "%{crate}" crate.
%files -n %{name}+legacy-ops-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+maths-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+maths-devel %{_description}
This package contains library source intended for building other packages which
use the "maths" feature of the "%{crate}" crate.
%files -n %{name}+maths-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+maths-nopanic-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+maths-nopanic-devel %{_description}
This package contains library source intended for building other packages which
use the "maths-nopanic" feature of the "%{crate}" crate.
%files -n %{name}+maths-nopanic-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rand-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rand-devel %{_description}
This package contains library source intended for building other packages which
use the "rand" feature of the "%{crate}" crate.
%files -n %{name}+rand-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rkyv-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rkyv-devel %{_description}
This package contains library source intended for building other packages which
use the "rkyv" feature of the "%{crate}" crate.
%files -n %{name}+rkyv-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rkyv-safe-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rkyv-safe-devel %{_description}
This package contains library source intended for building other packages which
use the "rkyv-safe" feature of the "%{crate}" crate.
%files -n %{name}+rkyv-safe-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel %package -n %{name}+serde-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch
@ -68,6 +187,102 @@ use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel %files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml %ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-arbitrary-precision-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-arbitrary-precision-devel %{_description}
This package contains library source intended for building other packages which
use the "serde-arbitrary-precision" feature of the "%{crate}" crate.
%files -n %{name}+serde-arbitrary-precision-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-bincode-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-bincode-devel %{_description}
This package contains library source intended for building other packages which
use the "serde-bincode" feature of the "%{crate}" crate.
%files -n %{name}+serde-bincode-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-float-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-float-devel %{_description}
This package contains library source intended for building other packages which
use the "serde-float" feature of the "%{crate}" crate.
%files -n %{name}+serde-float-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-str-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-str-devel %{_description}
This package contains library source intended for building other packages which
use the "serde-str" feature of the "%{crate}" crate.
%files -n %{name}+serde-str-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-with-arbitrary-precision-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-with-arbitrary-precision-devel %{_description}
This package contains library source intended for building other packages which
use the "serde-with-arbitrary-precision" feature of the "%{crate}" crate.
%files -n %{name}+serde-with-arbitrary-precision-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-with-float-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-with-float-devel %{_description}
This package contains library source intended for building other packages which
use the "serde-with-float" feature of the "%{crate}" crate.
%files -n %{name}+serde-with-float-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-with-str-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-with-str-devel %{_description}
This package contains library source intended for building other packages which
use the "serde-with-str" feature of the "%{crate}" crate.
%files -n %{name}+serde-with-str-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde_json-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde_json-devel %{_description}
This package contains library source intended for building other packages which
use the "serde_json" feature of the "%{crate}" crate.
%files -n %{name}+serde_json-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel %package -n %{name}+std-devel
Summary: %{summary} Summary: %{summary}
BuildArch: noarch BuildArch: noarch

@ -1,38 +0,0 @@
[DEFAULT]
unwanted-features =
c-repr
db-diesel-mysql
db-diesel-postgres
db-diesel1-mysql
db-diesel1-postgres
db-diesel2-mysql
db-diesel2-postgres
db-postgres
db-tokio-postgres
legacy-ops
maths
maths-nopanic
rkyv-safe
rocket-traits
rust-fuzz
serde-arbitrary-precision
serde-bincode
serde-float
serde-str
serde-with-arbitrary-precision
serde-with-float
serde-with-str
tokio-pg
arbitrary
borsh
bytecheck
byteorder
bytes
diesel1
diesel2
postgres
rand
rkyv
rocket
serde_json
tokio-postgres

@ -1,13 +1,142 @@
--- rust_decimal-1.26.1/Cargo.toml 1970-01-01T00:00:01+00:00 --- rust_decimal-1.28.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ rust_decimal-1.26.1/Cargo.toml 2022-08-06T10:10:14.264460+00:00 +++ rust_decimal-1.28.1/Cargo.toml 2023-02-22T18:16:22.240204+00:00
@@ -136,10 +136,6 @@ @@ -43,18 +43,8 @@
path = "benches/comparison.rs"
harness = false
-[dependencies.arbitrary]
-version = "1.0"
-optional = true
-default-features = false
-
[dependencies.arrayvec]
version = "0.7"
-default-features = false
-
-[dependencies.borsh]
-version = "0.10.0"
-optional = true
default-features = false
[dependencies.bytecheck]
@@ -72,26 +62,9 @@
optional = true
default-features = false
-[dependencies.diesel1]
-version = "1.0"
-optional = true
-default-features = false
-package = "diesel"
-
-[dependencies.diesel2]
-version = "2.0"
-optional = true
-default-features = false
-package = "diesel"
-
[dependencies.num-traits]
version = "0.2"
features = ["i128"]
-default-features = false
-
-[dependencies.postgres]
-version = "0.19"
-optional = true
default-features = false
[dependencies.rand]
@@ -108,11 +81,6 @@
optional = true
default-features = false
-[dependencies.rocket]
-version = "0.5.0-rc.1"
-optional = true
-default-features = false
-
[dependencies.serde]
version = "1.0" version = "1.0"
optional = true
@@ -123,21 +91,12 @@
optional = true
default-features = false default-features = false
-[dev-dependencies.criterion] -[dependencies.tokio-postgres]
-version = "0.3" -version = "0.7"
-optional = true
-default-features = false -default-features = false
- -
[dev-dependencies.bincode]
version = "1.0"
default-features = false
[dev-dependencies.bytes]
version = "1.0"
-default-features = false
-
-[dev-dependencies.criterion]
-version = "0.4.0"
default-features = false
[dev-dependencies.csv] [dev-dependencies.csv]
version = "1" @@ -179,37 +138,6 @@
[features]
c-repr = []
-db-diesel-mysql = ["db-diesel1-mysql"]
-db-diesel-postgres = ["db-diesel1-postgres"]
-db-diesel1-mysql = [
- "diesel1/mysql",
- "std",
-]
-db-diesel1-postgres = [
- "diesel1/postgres",
- "std",
-]
-db-diesel2-mysql = [
- "diesel2/mysql",
- "std",
-]
-db-diesel2-postgres = [
- "diesel2/postgres",
- "std",
-]
-db-postgres = [
- "byteorder",
- "bytes",
- "postgres",
- "std",
-]
-db-tokio-postgres = [
- "byteorder",
- "bytes",
- "postgres",
- "std",
- "tokio-postgres",
-]
default = [
"serde",
"std",
@@ -221,8 +149,6 @@
"bytecheck",
"rkyv/validation",
]
-rocket-traits = ["rocket"]
-rust-fuzz = ["arbitrary"]
serde = ["dep:serde"]
serde-arbitrary-precision = ["serde-with-arbitrary-precision"]
serde-bincode = ["serde-str"]
@@ -237,7 +163,6 @@
serde-with-str = ["serde"]
std = [
"arrayvec/std",
- "borsh?/std",
"bytecheck?/std",
"byteorder?/std",
"bytes?/std",
@@ -246,4 +171,3 @@
"serde?/std",
"serde_json?/std",
]
-tokio-pg = ["db-tokio-postgres"]

@ -1 +1 @@
SHA512 (rust_decimal-1.26.1.crate) = 776051a651af1c7bed2cc393c1538fac1900ed947e21f6846480b2f93b1ac651b6a4b45c601f1a8b33c6a8d255b798c4bbed4a1cdd4e79ddd0c0246d03bfa46e SHA512 (rust_decimal-1.28.1.crate) = 013cd690fd7095d5f63cdbd4cb5efe2f5c946184d267559987ada737b327eee20d59a04acf4f3c1ceafe88a967a1808947c5a6aa66780251d64821d0ca29bce8

Loading…
Cancel
Save