import rust-rust_decimal-1.36.0-1.el10

i10ce changed/i10ce/rust-rust_decimal-1.36.0-1.el10
MSVSphere Packaging Team 2 months ago
commit b7b17a1197
Signed by: sys_gitsync
GPG Key ID: B2B0B9F29E528FE8

1
.gitignore vendored

@ -0,0 +1 @@
SOURCES/rust_decimal-1.36.0.crate

@ -0,0 +1 @@
f3d8b39f940da6a277cfef3dd960a401b240d7fe SOURCES/rust_decimal-1.36.0.crate

@ -0,0 +1,31 @@
[package]
summary = "Decimal number implementation written in pure Rust"
cargo-toml-patch-comments = [
"drop unused postgres and tokio-postgres dev-dependencies",
"drop unused, benchmark-only criterion dev-dependency",
"drop unused features with missing dependencies",
]
[features]
hide = [
"db-diesel-mysql",
"db-diesel-postgres",
"db-diesel2-mysql",
"db-diesel2-postgres",
"db-postgres",
"db-tokio-postgres",
"diesel",
"ndarray",
"rocket-traits",
"rust-fuzz",
"tokio-pg",
"tokio-postgres",
]
[tests]
run = ["lib"]
comments = [
"doctests can only be compiled and run in-tree",
"integration tests require files which are not included in published crates",
]

@ -0,0 +1,68 @@
--- rust_decimal-1.36.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ rust_decimal-1.36.0/Cargo.toml 2024-09-18T21:27:10.217746+00:00
@@ -80,15 +80,6 @@
version = "0.7"
default-features = false
-[dependencies.borsh]
-version = "1.1.1"
-features = [
- "derive",
- "unstable__schema",
-]
-optional = true
-default-features = false
-
[dependencies.bytes]
version = "1.0"
optional = true
@@ -162,19 +153,11 @@
version = "1.0"
default-features = false
-[dev-dependencies.criterion]
-version = "0.5"
-default-features = false
-
[dev-dependencies.csv]
version = "1"
[dev-dependencies.futures]
version = "0.3"
-default-features = false
-
-[dev-dependencies.postgres]
-version = "0.19"
default-features = false
[dev-dependencies.rand]
@@ -201,10 +184,6 @@
"rt-multi-thread",
"test-util",
]
-default-features = false
-
-[dev-dependencies.tokio-postgres]
-version = "0.7"
default-features = false
[dev-dependencies.version-sync]
@@ -216,10 +195,6 @@
default-features = false
[features]
-borsh = [
- "dep:borsh",
- "std",
-]
c-repr = []
db-diesel-mysql = [
"diesel/mysql",
@@ -269,7 +244,6 @@
serde-with-str = ["serde"]
std = [
"arrayvec/std",
- "borsh?/std",
"bytes?/std",
"rand?/std",
"rkyv?/std",

@ -0,0 +1,457 @@
## START: Set by rpmautospec
## (rpmautospec version 0.7.2)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate rust_decimal
Name: rust-rust_decimal
Version: 1.36.0
Release: %autorelease
Summary: Decimal number implementation written in pure Rust
License: MIT
URL: https://crates.io/crates/rust_decimal
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop unused postgres and tokio-postgres dev-dependencies
# * drop unused, benchmark-only criterion dev-dependency
# * drop unused features with missing dependencies
Patch: rust_decimal-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Decimal number implementation written in pure Rust suitable for
financial and fixed-precision calculations.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/BUILD.md
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/CODE_OF_CONDUCT.md
%doc %{crate_instdir}/CONTRIBUTING.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+c-repr-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+c-repr-devel %{_description}
This package contains library source intended for building other packages which
use the "c-repr" feature of the "%{crate}" crate.
%files -n %{name}+c-repr-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+legacy-ops-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+legacy-ops-devel %{_description}
This package contains library source intended for building other packages which
use the "legacy-ops" feature of the "%{crate}" crate.
%files -n %{name}+legacy-ops-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+maths-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+maths-devel %{_description}
This package contains library source intended for building other packages which
use the "maths" feature of the "%{crate}" crate.
%files -n %{name}+maths-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+maths-nopanic-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+maths-nopanic-devel %{_description}
This package contains library source intended for building other packages which
use the "maths-nopanic" feature of the "%{crate}" crate.
%files -n %{name}+maths-nopanic-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+proptest-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+proptest-devel %{_description}
This package contains library source intended for building other packages which
use the "proptest" feature of the "%{crate}" crate.
%files -n %{name}+proptest-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rand-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rand-devel %{_description}
This package contains library source intended for building other packages which
use the "rand" feature of the "%{crate}" crate.
%files -n %{name}+rand-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rkyv-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rkyv-devel %{_description}
This package contains library source intended for building other packages which
use the "rkyv" feature of the "%{crate}" crate.
%files -n %{name}+rkyv-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rkyv-safe-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rkyv-safe-devel %{_description}
This package contains library source intended for building other packages which
use the "rkyv-safe" feature of the "%{crate}" crate.
%files -n %{name}+rkyv-safe-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-arbitrary-precision-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-arbitrary-precision-devel %{_description}
This package contains library source intended for building other packages which
use the "serde-arbitrary-precision" feature of the "%{crate}" crate.
%files -n %{name}+serde-arbitrary-precision-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-bincode-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-bincode-devel %{_description}
This package contains library source intended for building other packages which
use the "serde-bincode" feature of the "%{crate}" crate.
%files -n %{name}+serde-bincode-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-float-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-float-devel %{_description}
This package contains library source intended for building other packages which
use the "serde-float" feature of the "%{crate}" crate.
%files -n %{name}+serde-float-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-str-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-str-devel %{_description}
This package contains library source intended for building other packages which
use the "serde-str" feature of the "%{crate}" crate.
%files -n %{name}+serde-str-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-with-arbitrary-precision-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-with-arbitrary-precision-devel %{_description}
This package contains library source intended for building other packages which
use the "serde-with-arbitrary-precision" feature of the "%{crate}" crate.
%files -n %{name}+serde-with-arbitrary-precision-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-with-float-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-with-float-devel %{_description}
This package contains library source intended for building other packages which
use the "serde-with-float" feature of the "%{crate}" crate.
%files -n %{name}+serde-with-float-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-with-str-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-with-str-devel %{_description}
This package contains library source intended for building other packages which
use the "serde-with-str" feature of the "%{crate}" crate.
%files -n %{name}+serde-with-str-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde_json-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde_json-devel %{_description}
This package contains library source intended for building other packages which
use the "serde_json" feature of the "%{crate}" crate.
%files -n %{name}+serde_json-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
# * doctests can only be compiled and run in-tree
# * integration tests require files which are not included in published crates
%cargo_test -- --lib
%endif
%changelog
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 1.36.0-1
- Rebuilt for MSVSphere 10
## START: Generated by rpmautospec
* Wed Sep 18 2024 Fabio Valentini <decathorpe@gmail.com> - 1.36.0-1
- Update to version 1.36.0; Fixes RHBZ#2306093
* Sat Jul 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.35.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
* Thu Apr 25 2024 Fabio Valentini <decathorpe@gmail.com> - 1.35.0-1
- Update to version 1.35.0; Fixes RHBZ#2271712
* Mon Feb 19 2024 Fabio Valentini <decathorpe@gmail.com> - 1.34.3-1
- Update to version 1.34.3; Fixes RHBZ#2262142
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.33.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Fri Nov 17 2023 Fabio Valentini <decathorpe@gmail.com> - 1.33.1-1
- Update to version 1.33.1; Fixes RHBZ#2249575
* Sun Aug 27 2023 Fabio Valentini <decathorpe@gmail.com> - 1.32.0-1
- Update to version 1.32.0; Fixes RHBZ#2233882
* Tue Aug 01 2023 Fabio Valentini <decathorpe@gmail.com> - 1.31.0-1
- Update to version 1.31.0; Fixes RHBZ#2227474
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.30.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Sat Jun 24 2023 Fabio Valentini <decathorpe@gmail.com> - 1.30.0-1
- Update to version 1.30.0; Fixes RHBZ#2215186
* Sun Mar 26 2023 Fabio Valentini <decathorpe@gmail.com> - 1.29.1-1
- Update to version 1.29.1; Fixes RHBZ#2181680
* Sun Mar 12 2023 Fabio Valentini <decathorpe@gmail.com> - 1.29.0-1
- Update to version 1.29.0; Fixes RHBZ#2177465
* Wed Feb 22 2023 Fabio Valentini <decathorpe@gmail.com> - 1.28.1-1
- Update to version 1.28.1; Fixes RHBZ#2148310
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.26.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Sat Aug 06 2022 Fabio Valentini <decathorpe@gmail.com> - 1.26.1-1
- Update to version 1.26.1; Fixes RHBZ#2115620
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.25.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Sat Jul 16 2022 Fabio Valentini <decathorpe@gmail.com> - 1.25.0-1
- Update to version 1.25.0; Fixes RHBZ#2092157
* Tue Mar 29 2022 Fabio Valentini <decathorpe@gmail.com> - 1.23.1-1
- Update to version 1.23.1; Fixes RHBZ#2068766
* Sat Mar 05 2022 Fabio Valentini <decathorpe@gmail.com> - 1.22.0-1
- Update to version 1.22.0; Fixes RHBZ#2056215
* Mon Jan 31 2022 Fabio Valentini <decathorpe@gmail.com> - 1.21.0-1
- Update to version 1.21.0; Fixes RHBZ#2048799
* Thu Jan 27 2022 Fabio Valentini <decathorpe@gmail.com> - 1.20.0-1
- Update to version 1.20.0; Fixes RHBZ#2039152
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.19.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Fri Jan 07 2022 Fabio Valentini <decathorpe@gmail.com> - 1.19.0-1
- Update to version 1.19.0; Fixes RHBZ#2035573
* Wed Dec 01 2021 Fabio Valentini <decathorpe@gmail.com> - 1.18.0-1
- Update to version 1.18.0; Fixes RHBZ#2027918
* Fri Nov 05 2021 Fabio Valentini <decathorpe@gmail.com> - 1.17.0-1
- Update to version 1.17.0; Fixes RHBZ#2016568
* Thu Sep 30 2021 Fabio Valentini <decathorpe@gmail.com> - 1.16.0-1
- Update to version 1.16.0; Fixes RHBZ#2004291
* Wed Jul 28 2021 Fabio Valentini <decathorpe@gmail.com> - 1.15.0-1
- Update to version 1.15.0; Fixes RHBZ#1986673
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.14.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Sat Jun 19 2021 Fabio Valentini <decathorpe@gmail.com> - 1.14.3-1
- Update to version 1.14.3.
- Fixes RHBZ#1968685
* Thu May 27 2021 Fabio Valentini <decathorpe@gmail.com> - 1.14.1-1
- Update to version 1.14.1.
- Fixes RHBZ#1963746
* Thu May 06 2021 Fabio Valentini <decathorpe@gmail.com> - 1.13.0-1
- Update to version 1.13.0.
- Fixes RHBZ#1953064
* Wed Apr 21 2021 Fabio Valentini <decathorpe@gmail.com> - 1.11.1-1
- Update to version 1.11.1.
- Fixes RHBZ#1950566
* Sat Feb 27 2021 Fabio Valentini <decathorpe@gmail.com> - 1.10.3-1
- Update to version 1.10.3.
- Fixes RHBZ#1928883
* Sun Feb 07 2021 Fabio Valentini <decathorpe@gmail.com> - 1.10.2-1
- Update to version 1.10.2.
- Fixes RHBZ#1911306
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Sat Dec 12 2020 Fabio Valentini <decathorpe@gmail.com> - 1.8.1-2
- Remove features with missing dependencies (postgres, tokio-postgres).
* Wed Sep 23 2020 Fabio Valentini <decathorpe@gmail.com> - 1.8.1-1
- Update to version 1.8.1.
* Wed Jul 29 2020 Josh Stone <jistone@redhat.com> - 1.7.0-1
- Update to 1.7.0
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Wed May 20 09:07:19 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 1.6.0-1
- Update to 1.6.0
* Fri May 08 2020 Josh Stone <jistone@redhat.com> - 1.5.0-1
- Update to 1.5.0
* Wed Apr 15 2020 Josh Stone <jistone@redhat.com> - 1.4.1-1
- Update to 1.4.1
* Mon Mar 23 06:53:16 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 1.4.0-1
- Update to 1.4.0
* Fri Feb 28 19:14:48 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 1.3.0-1
- Update to 1.3.0
* Tue Feb 11 09:58:57 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 1.2.1-1
- Update to 1.2.1
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Fri Dec 06 17:34:29 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.0.3-1
- Initial package
## END: Generated by rpmautospec
Loading…
Cancel
Save