Update to version 1.29.0; Fixes RHBZ#2177465

epel9
Fabio Valentini 2 years ago
parent c318f55721
commit 2941d12a91
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -25,3 +25,4 @@
/rust_decimal-1.25.0.crate
/rust_decimal-1.26.1.crate
/rust_decimal-1.28.1.crate
/rust_decimal-1.29.0.crate

@ -5,7 +5,7 @@
%global crate rust_decimal
Name: rust-rust_decimal
Version: 1.28.1
Version: 1.29.0
Release: %autorelease
Summary: Decimal number implementation written in pure Rust
@ -55,18 +55,6 @@ use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bytecheck-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+bytecheck-devel %{_description}
This package contains library source intended for building other packages which
use the "bytecheck" feature of the "%{crate}" crate.
%files -n %{name}+bytecheck-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+byteorder-devel
Summary: %{summary}
BuildArch: noarch

@ -1,5 +1,5 @@
--- rust_decimal-1.28.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ rust_decimal-1.28.1/Cargo.toml 2023-02-22T18:16:22.240204+00:00
--- rust_decimal-1.29.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ rust_decimal-1.29.0/Cargo.toml 2023-03-12T14:23:53.397888+00:00
@@ -43,18 +43,8 @@
path = "benches/comparison.rs"
harness = false
@ -80,9 +80,14 @@
default-features = false
[dev-dependencies.csv]
@@ -179,37 +138,6 @@
@@ -178,42 +137,7 @@
default-features = false
[features]
-borsh = [
- "dep:borsh",
- "std",
-]
c-repr = []
-db-diesel-mysql = ["db-diesel1-mysql"]
-db-diesel-postgres = ["db-diesel1-postgres"]
@ -103,31 +108,31 @@
- "std",
-]
-db-postgres = [
- "byteorder",
- "bytes",
- "postgres",
- "dep:byteorder",
- "dep:bytes",
- "dep:postgres",
- "std",
-]
-db-tokio-postgres = [
- "byteorder",
- "bytes",
- "postgres",
- "dep:byteorder",
- "dep:bytes",
- "dep:postgres",
- "std",
- "tokio-postgres",
- "dep:tokio-postgres",
-]
default = [
"serde",
"std",
@@ -221,8 +149,6 @@
"bytecheck",
@@ -227,8 +151,6 @@
"dep:bytecheck",
"rkyv/validation",
]
-rocket-traits = ["rocket"]
-rust-fuzz = ["arbitrary"]
-rocket-traits = ["dep:rocket"]
-rust-fuzz = ["dep:arbitrary"]
serde = ["dep:serde"]
serde-arbitrary-precision = ["serde-with-arbitrary-precision"]
serde-bincode = ["serde-str"]
@@ -237,7 +163,6 @@
@@ -243,7 +165,6 @@
serde-with-str = ["serde"]
std = [
"arrayvec/std",
@ -135,7 +140,7 @@
"bytecheck?/std",
"byteorder?/std",
"bytes?/std",
@@ -246,4 +171,3 @@
@@ -252,4 +173,3 @@
"serde?/std",
"serde_json?/std",
]

@ -1 +1 @@
SHA512 (rust_decimal-1.28.1.crate) = 013cd690fd7095d5f63cdbd4cb5efe2f5c946184d267559987ada737b327eee20d59a04acf4f3c1ceafe88a967a1808947c5a6aa66780251d64821d0ca29bce8
SHA512 (rust_decimal-1.29.0.crate) = 8f8febce7f2954d14d59791af1356674db241cbbbab4b8c6cfca2af537158b3197a9d71ea38626af6ccc980770f2816a78c31137dba3685763aabc89f01f1f61

Loading…
Cancel
Save