Update to version 1.30.0; Fixes RHBZ#2215186

epel9
Fabio Valentini 2 years ago
parent 093609c1a6
commit 1b50b54a09
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -27,3 +27,4 @@
/rust_decimal-1.28.1.crate
/rust_decimal-1.29.0.crate
/rust_decimal-1.29.1.crate
/rust_decimal-1.30.0.crate

@ -5,7 +5,7 @@
%global crate rust_decimal
Name: rust-rust_decimal
Version: 1.29.1
Version: 1.30.0
Release: %autorelease
Summary: Decimal number implementation written in pure Rust
@ -127,6 +127,18 @@ use the "maths-nopanic" feature of the "%{crate}" crate.
%files -n %{name}+maths-nopanic-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+proptest-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+proptest-devel %{_description}
This package contains library source intended for building other packages which
use the "proptest" feature of the "%{crate}" crate.
%files -n %{name}+proptest-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rand-devel
Summary: %{summary}
BuildArch: noarch
@ -298,7 +310,7 @@ use the "std" feature of the "%{crate}" crate.
%if %{with check}
%check
# * doctests fail to compile due to undeclared rust_decimal_macros dependency
# * doctests can only be compiled and run in-tree
# * integration tests require files which are not included in published crates
%cargo_test -- --lib
%endif

@ -0,0 +1,2 @@
[DEFAULT]
summary = Decimal number implementation written in pure Rust

@ -1,5 +1,5 @@
--- rust_decimal-1.29.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ rust_decimal-1.29.1/Cargo.toml 2023-03-26T16:17:21.810596+00:00
--- rust_decimal-1.30.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ rust_decimal-1.30.0/Cargo.toml 2023-06-24T22:19:10.021160+00:00
@@ -43,18 +43,8 @@
path = "benches/comparison.rs"
harness = false
@ -50,8 +50,8 @@
-optional = true
default-features = false
[dependencies.rand]
@@ -113,11 +81,6 @@
[dependencies.proptest]
@@ -119,11 +87,6 @@
optional = true
default-features = false
@ -63,7 +63,7 @@
[dependencies.serde]
version = "1.0"
optional = true
@@ -128,21 +91,12 @@
@@ -134,21 +97,12 @@
optional = true
default-features = false
@ -85,7 +85,7 @@
default-features = false
[dev-dependencies.csv]
@@ -183,42 +137,7 @@
@@ -189,42 +143,7 @@
default-features = false
[features]
@ -128,14 +128,15 @@
default = [
"serde",
"std",
@@ -226,15 +145,12 @@
@@ -232,7 +151,6 @@
legacy-ops = []
maths = []
maths-nopanic = ["maths"]
-ndarray = ["dep:ndarray"]
proptest = ["dep:proptest"]
rand = ["dep:rand"]
rkyv = ["dep:rkyv"]
rkyv-safe = [
@@ -240,8 +158,6 @@
"dep:bytecheck",
"rkyv/validation",
]
@ -144,7 +145,7 @@
serde = ["dep:serde"]
serde-arbitrary-precision = ["serde-with-arbitrary-precision"]
serde-bincode = ["serde-str"]
@@ -249,7 +165,6 @@
@@ -256,7 +172,6 @@
serde-with-str = ["serde"]
std = [
"arrayvec/std",
@ -152,7 +153,7 @@
"bytecheck?/std",
"byteorder?/std",
"bytes?/std",
@@ -258,4 +173,3 @@
@@ -265,4 +180,3 @@
"serde?/std",
"serde_json?/std",
]

@ -1 +1 @@
SHA512 (rust_decimal-1.29.1.crate) = 0a60b8f933cc07931707a1a7fec61af9059c68477906ec65b94acd6376ffbd04beec93018bafed9f0677a50557fc1ae2014ceb749cfe30f798e82cb07db8d45e
SHA512 (rust_decimal-1.30.0.crate) = 47b33e3a08891dd5c22f78dfe8ad4ccd6cbe9fa41b147c9a5e41ef23615674370b41c32ea5d868014e08b1b81a8852c1438f5cf7db33f82fcecf3034c27a8dfd

Loading…
Cancel
Save