|
|
@ -1,5 +1,5 @@
|
|
|
|
--- rust_decimal-1.30.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
|
|
|
--- rust_decimal-1.31.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
|
|
|
+++ rust_decimal-1.30.0/Cargo.toml 2023-06-24T22:19:10.021160+00:00
|
|
|
|
+++ rust_decimal-1.31.0/Cargo.toml 2023-08-01T11:34:04.156774+00:00
|
|
|
|
@@ -43,18 +43,8 @@
|
|
|
|
@@ -43,18 +43,8 @@
|
|
|
|
path = "benches/comparison.rs"
|
|
|
|
path = "benches/comparison.rs"
|
|
|
|
harness = false
|
|
|
|
harness = false
|
|
|
@ -18,8 +18,8 @@
|
|
|
|
-optional = true
|
|
|
|
-optional = true
|
|
|
|
default-features = false
|
|
|
|
default-features = false
|
|
|
|
|
|
|
|
|
|
|
|
[dependencies.bytecheck]
|
|
|
|
[dependencies.byteorder]
|
|
|
|
@@ -72,31 +62,9 @@
|
|
|
|
@@ -67,31 +57,9 @@
|
|
|
|
optional = true
|
|
|
|
optional = true
|
|
|
|
default-features = false
|
|
|
|
default-features = false
|
|
|
|
|
|
|
|
|
|
|
@ -30,7 +30,7 @@
|
|
|
|
-package = "diesel"
|
|
|
|
-package = "diesel"
|
|
|
|
-
|
|
|
|
-
|
|
|
|
-[dependencies.diesel2]
|
|
|
|
-[dependencies.diesel2]
|
|
|
|
-version = "2.0"
|
|
|
|
-version = "2.1"
|
|
|
|
-optional = true
|
|
|
|
-optional = true
|
|
|
|
-default-features = false
|
|
|
|
-default-features = false
|
|
|
|
-package = "diesel"
|
|
|
|
-package = "diesel"
|
|
|
@ -51,19 +51,19 @@
|
|
|
|
default-features = false
|
|
|
|
default-features = false
|
|
|
|
|
|
|
|
|
|
|
|
[dependencies.proptest]
|
|
|
|
[dependencies.proptest]
|
|
|
|
@@ -119,11 +87,6 @@
|
|
|
|
@@ -114,11 +82,6 @@
|
|
|
|
optional = true
|
|
|
|
optional = true
|
|
|
|
default-features = false
|
|
|
|
default-features = false
|
|
|
|
|
|
|
|
|
|
|
|
-[dependencies.rocket]
|
|
|
|
-[dependencies.rocket]
|
|
|
|
-version = "0.5.0-rc.1"
|
|
|
|
-version = "0.5.0-rc.3"
|
|
|
|
-optional = true
|
|
|
|
-optional = true
|
|
|
|
-default-features = false
|
|
|
|
-default-features = false
|
|
|
|
-
|
|
|
|
-
|
|
|
|
[dependencies.serde]
|
|
|
|
[dependencies.serde]
|
|
|
|
version = "1.0"
|
|
|
|
version = "1.0"
|
|
|
|
optional = true
|
|
|
|
optional = true
|
|
|
|
@@ -134,21 +97,12 @@
|
|
|
|
@@ -129,21 +92,12 @@
|
|
|
|
optional = true
|
|
|
|
optional = true
|
|
|
|
default-features = false
|
|
|
|
default-features = false
|
|
|
|
|
|
|
|
|
|
|
@ -81,11 +81,11 @@
|
|
|
|
-default-features = false
|
|
|
|
-default-features = false
|
|
|
|
-
|
|
|
|
-
|
|
|
|
-[dev-dependencies.criterion]
|
|
|
|
-[dev-dependencies.criterion]
|
|
|
|
-version = "0.4.0"
|
|
|
|
-version = "0.5"
|
|
|
|
default-features = false
|
|
|
|
default-features = false
|
|
|
|
|
|
|
|
|
|
|
|
[dev-dependencies.csv]
|
|
|
|
[dev-dependencies.csv]
|
|
|
|
@@ -189,42 +143,7 @@
|
|
|
|
@@ -184,42 +138,7 @@
|
|
|
|
default-features = false
|
|
|
|
default-features = false
|
|
|
|
|
|
|
|
|
|
|
|
[features]
|
|
|
|
[features]
|
|
|
@ -128,7 +128,7 @@
|
|
|
|
default = [
|
|
|
|
default = [
|
|
|
|
"serde",
|
|
|
|
"serde",
|
|
|
|
"std",
|
|
|
|
"std",
|
|
|
|
@@ -232,7 +151,6 @@
|
|
|
|
@@ -227,13 +146,10 @@
|
|
|
|
legacy-ops = []
|
|
|
|
legacy-ops = []
|
|
|
|
maths = []
|
|
|
|
maths = []
|
|
|
|
maths-nopanic = ["maths"]
|
|
|
|
maths-nopanic = ["maths"]
|
|
|
@ -136,24 +136,21 @@
|
|
|
|
proptest = ["dep:proptest"]
|
|
|
|
proptest = ["dep:proptest"]
|
|
|
|
rand = ["dep:rand"]
|
|
|
|
rand = ["dep:rand"]
|
|
|
|
rkyv = ["dep:rkyv"]
|
|
|
|
rkyv = ["dep:rkyv"]
|
|
|
|
@@ -240,8 +158,6 @@
|
|
|
|
rkyv-safe = ["rkyv/validation"]
|
|
|
|
"dep:bytecheck",
|
|
|
|
|
|
|
|
"rkyv/validation",
|
|
|
|
|
|
|
|
]
|
|
|
|
|
|
|
|
-rocket-traits = ["dep:rocket"]
|
|
|
|
-rocket-traits = ["dep:rocket"]
|
|
|
|
-rust-fuzz = ["dep:arbitrary"]
|
|
|
|
-rust-fuzz = ["dep:arbitrary"]
|
|
|
|
serde = ["dep:serde"]
|
|
|
|
serde = ["dep:serde"]
|
|
|
|
serde-arbitrary-precision = ["serde-with-arbitrary-precision"]
|
|
|
|
serde-arbitrary-precision = ["serde-with-arbitrary-precision"]
|
|
|
|
serde-bincode = ["serde-str"]
|
|
|
|
serde-bincode = ["serde-str"]
|
|
|
|
@@ -256,7 +172,6 @@
|
|
|
|
@@ -248,7 +164,6 @@
|
|
|
|
serde-with-str = ["serde"]
|
|
|
|
serde-with-str = ["serde"]
|
|
|
|
std = [
|
|
|
|
std = [
|
|
|
|
"arrayvec/std",
|
|
|
|
"arrayvec/std",
|
|
|
|
- "borsh?/std",
|
|
|
|
- "borsh?/std",
|
|
|
|
"bytecheck?/std",
|
|
|
|
|
|
|
|
"byteorder?/std",
|
|
|
|
"byteorder?/std",
|
|
|
|
"bytes?/std",
|
|
|
|
"bytes?/std",
|
|
|
|
@@ -265,4 +180,3 @@
|
|
|
|
"rand?/std",
|
|
|
|
|
|
|
|
@@ -256,4 +171,3 @@
|
|
|
|
"serde?/std",
|
|
|
|
"serde?/std",
|
|
|
|
"serde_json?/std",
|
|
|
|
"serde_json?/std",
|
|
|
|
]
|
|
|
|
]
|
|
|
|