|
|
|
@ -1,5 +1,5 @@
|
|
|
|
|
--- rust_decimal-1.29.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
|
|
|
|
+++ rust_decimal-1.29.0/Cargo.toml 2023-03-12T14:23:53.397888+00:00
|
|
|
|
|
--- rust_decimal-1.29.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
|
|
|
|
+++ rust_decimal-1.29.1/Cargo.toml 2023-03-26T16:17:21.810596+00:00
|
|
|
|
|
@@ -43,18 +43,8 @@
|
|
|
|
|
path = "benches/comparison.rs"
|
|
|
|
|
harness = false
|
|
|
|
@ -19,7 +19,7 @@
|
|
|
|
|
default-features = false
|
|
|
|
|
|
|
|
|
|
[dependencies.bytecheck]
|
|
|
|
|
@@ -72,26 +62,9 @@
|
|
|
|
|
@@ -72,31 +62,9 @@
|
|
|
|
|
optional = true
|
|
|
|
|
default-features = false
|
|
|
|
|
|
|
|
|
@ -34,6 +34,11 @@
|
|
|
|
|
-optional = true
|
|
|
|
|
-default-features = false
|
|
|
|
|
-package = "diesel"
|
|
|
|
|
-
|
|
|
|
|
-[dependencies.ndarray]
|
|
|
|
|
-version = "0.15.6"
|
|
|
|
|
-optional = true
|
|
|
|
|
-default-features = false
|
|
|
|
|
-
|
|
|
|
|
[dependencies.num-traits]
|
|
|
|
|
version = "0.2"
|
|
|
|
@ -46,7 +51,7 @@
|
|
|
|
|
default-features = false
|
|
|
|
|
|
|
|
|
|
[dependencies.rand]
|
|
|
|
|
@@ -108,11 +81,6 @@
|
|
|
|
|
@@ -113,11 +81,6 @@
|
|
|
|
|
optional = true
|
|
|
|
|
default-features = false
|
|
|
|
|
|
|
|
|
@ -58,7 +63,7 @@
|
|
|
|
|
[dependencies.serde]
|
|
|
|
|
version = "1.0"
|
|
|
|
|
optional = true
|
|
|
|
|
@@ -123,21 +91,12 @@
|
|
|
|
|
@@ -128,21 +91,12 @@
|
|
|
|
|
optional = true
|
|
|
|
|
default-features = false
|
|
|
|
|
|
|
|
|
@ -80,7 +85,7 @@
|
|
|
|
|
default-features = false
|
|
|
|
|
|
|
|
|
|
[dev-dependencies.csv]
|
|
|
|
|
@@ -178,42 +137,7 @@
|
|
|
|
|
@@ -183,42 +137,7 @@
|
|
|
|
|
default-features = false
|
|
|
|
|
|
|
|
|
|
[features]
|
|
|
|
@ -123,7 +128,14 @@
|
|
|
|
|
default = [
|
|
|
|
|
"serde",
|
|
|
|
|
"std",
|
|
|
|
|
@@ -227,8 +151,6 @@
|
|
|
|
|
@@ -226,15 +145,12 @@
|
|
|
|
|
legacy-ops = []
|
|
|
|
|
maths = []
|
|
|
|
|
maths-nopanic = ["maths"]
|
|
|
|
|
-ndarray = ["dep:ndarray"]
|
|
|
|
|
rand = ["dep:rand"]
|
|
|
|
|
rkyv = ["dep:rkyv"]
|
|
|
|
|
rkyv-safe = [
|
|
|
|
|
"dep:bytecheck",
|
|
|
|
|
"rkyv/validation",
|
|
|
|
|
]
|
|
|
|
@ -132,7 +144,7 @@
|
|
|
|
|
serde = ["dep:serde"]
|
|
|
|
|
serde-arbitrary-precision = ["serde-with-arbitrary-precision"]
|
|
|
|
|
serde-bincode = ["serde-str"]
|
|
|
|
|
@@ -243,7 +165,6 @@
|
|
|
|
|
@@ -249,7 +165,6 @@
|
|
|
|
|
serde-with-str = ["serde"]
|
|
|
|
|
std = [
|
|
|
|
|
"arrayvec/std",
|
|
|
|
@ -140,7 +152,7 @@
|
|
|
|
|
"bytecheck?/std",
|
|
|
|
|
"byteorder?/std",
|
|
|
|
|
"bytes?/std",
|
|
|
|
|
@@ -252,4 +173,3 @@
|
|
|
|
|
@@ -258,4 +173,3 @@
|
|
|
|
|
"serde?/std",
|
|
|
|
|
"serde_json?/std",
|
|
|
|
|
]
|
|
|
|
|